summaryrefslogtreecommitdiffstats
path: root/src/imports/texture-sharing-extension/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/texture-sharing-extension/CMakeLists.txt')
-rw-r--r--src/imports/texture-sharing-extension/CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/src/imports/texture-sharing-extension/CMakeLists.txt b/src/imports/texture-sharing-extension/CMakeLists.txt
index cb8aa75ba..564bb6402 100644
--- a/src/imports/texture-sharing-extension/CMakeLists.txt
+++ b/src/imports/texture-sharing-extension/CMakeLists.txt
@@ -1,17 +1,24 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from texture-sharing-extension.pro.
#####################################################################
## qwaylandtexturesharingextension Plugin:
#####################################################################
-qt_internal_add_qml_module(qwaylandtexturesharingextension
+qt_internal_add_qml_module(WaylandTextureSharingExtension
URI "QtWayland.Compositor.TextureSharingExtension"
- VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
- CLASSNAME QWaylandTextureSharingExtensionPlugin
- SKIP_TYPE_REGISTRATION
+ VERSION "1.${PROJECT_VERSION_MINOR}"
+ CLASS_NAME QWaylandTextureSharingExtensionPlugin
+ NO_PLUGIN_OPTIONAL
+ NO_GENERATE_PLUGIN_SOURCE
+ NO_GENERATE_QMLTYPES
+ PLUGIN_TARGET WaylandTextureSharingExtension
+ # misses a plugin.qmltypes files, so nothing to install
SOURCES
plugin.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::CorePrivate
Qt::Gui
@@ -20,8 +27,10 @@ qt_internal_add_qml_module(qwaylandtexturesharingextension
Qt::QuickPrivate
Qt::WaylandCompositor
Qt::WaylandCompositorPrivate
+ NO_GENERATE_CPP_EXPORTS
)
+qt_internal_add_autogen_sync_header_dependencies(WaylandTextureSharingExtension WaylandCompositor)
#### Keys ignored in scope 1:.:.:texture-sharing-extension.pro:<TRUE>:
# CXX_MODULE = "qml"
# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"