summaryrefslogtreecommitdiffstats
path: root/src/imports/texture-sharing-extension
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/texture-sharing-extension')
-rw-r--r--src/imports/texture-sharing-extension/CMakeLists.txt19
-rw-r--r--src/imports/texture-sharing-extension/plugin.cpp44
-rw-r--r--src/imports/texture-sharing-extension/qmldir4
-rw-r--r--src/imports/texture-sharing-extension/texture-sharing-extension.pro11
4 files changed, 20 insertions, 58 deletions
diff --git a/src/imports/texture-sharing-extension/CMakeLists.txt b/src/imports/texture-sharing-extension/CMakeLists.txt
index cb8aa75ba..564bb6402 100644
--- a/src/imports/texture-sharing-extension/CMakeLists.txt
+++ b/src/imports/texture-sharing-extension/CMakeLists.txt
@@ -1,17 +1,24 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from texture-sharing-extension.pro.
#####################################################################
## qwaylandtexturesharingextension Plugin:
#####################################################################
-qt_internal_add_qml_module(qwaylandtexturesharingextension
+qt_internal_add_qml_module(WaylandTextureSharingExtension
URI "QtWayland.Compositor.TextureSharingExtension"
- VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
- CLASSNAME QWaylandTextureSharingExtensionPlugin
- SKIP_TYPE_REGISTRATION
+ VERSION "1.${PROJECT_VERSION_MINOR}"
+ CLASS_NAME QWaylandTextureSharingExtensionPlugin
+ NO_PLUGIN_OPTIONAL
+ NO_GENERATE_PLUGIN_SOURCE
+ NO_GENERATE_QMLTYPES
+ PLUGIN_TARGET WaylandTextureSharingExtension
+ # misses a plugin.qmltypes files, so nothing to install
SOURCES
plugin.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::CorePrivate
Qt::Gui
@@ -20,8 +27,10 @@ qt_internal_add_qml_module(qwaylandtexturesharingextension
Qt::QuickPrivate
Qt::WaylandCompositor
Qt::WaylandCompositorPrivate
+ NO_GENERATE_CPP_EXPORTS
)
+qt_internal_add_autogen_sync_header_dependencies(WaylandTextureSharingExtension WaylandCompositor)
#### Keys ignored in scope 1:.:.:texture-sharing-extension.pro:<TRUE>:
# CXX_MODULE = "qml"
# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
diff --git a/src/imports/texture-sharing-extension/plugin.cpp b/src/imports/texture-sharing-extension/plugin.cpp
index 42dcd8e2d..6fd6032ac 100644
--- a/src/imports/texture-sharing-extension/plugin.cpp
+++ b/src/imports/texture-sharing-extension/plugin.cpp
@@ -1,41 +1,5 @@
-/****************************************************************************
-**
-** Copyright (C) 2019 The Qt Company Ltd.
-** Contact: https://www.qt.io/licensing/
-**
-** This file is part of the QtWaylandCompositor module of the Qt Toolkit.
-**
-** $QT_BEGIN_LICENSE:LGPL$
-** Commercial License Usage
-** Licensees holding valid commercial Qt licenses may use this file in
-** accordance with the commercial license agreement provided with the
-** Software or, alternatively, in accordance with the terms contained in
-** a written agreement between you and The Qt Company. For licensing terms
-** and conditions see https://www.qt.io/terms-conditions. For further
-** information use the contact form at https://www.qt.io/contact-us.
-**
-** GNU Lesser General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU Lesser
-** General Public License version 3 as published by the Free Software
-** Foundation and appearing in the file LICENSE.LGPL3 included in the
-** packaging of this file. Please review the following information to
-** ensure the GNU Lesser General Public License version 3 requirements
-** will be met: https://www.gnu.org/licenses/lgpl-3.0.html.
-**
-** GNU General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU
-** General Public License version 2.0 or (at your option) the GNU General
-** Public license version 3 or any later version approved by the KDE Free
-** Qt Foundation. The licenses are as published by the Free Software
-** Foundation and appearing in the file LICENSE.GPL2 and LICENSE.GPL3
-** included in the packaging of this file. Please review the following
-** information to ensure the GNU General Public License requirements will
-** be met: https://www.gnu.org/licenses/gpl-2.0.html and
-** https://www.gnu.org/licenses/gpl-3.0.html.
-**
-** $QT_END_LICENSE$
-**
-****************************************************************************/
+// Copyright (C) 2019 The Qt Company Ltd.
+// SPDX-License-Identifier: LicenseRef-Qt-Commercial OR LGPL-3.0-only OR GPL-2.0-only OR GPL-3.0-only
#include <QtQml/qqmlextensionplugin.h>
#include <QtQml/qqmlengine.h>
@@ -43,6 +7,7 @@
#include "QtWaylandCompositor/private/qwltexturesharingextension_p.h"
/*!
+ \internal
\qmlmodule QtWayland.Compositor.TextureSharingExtension 1
\title Qt Wayland Shared Texture Provider
\ingroup qmlmodules
@@ -53,6 +18,9 @@
This module lets the compositor export graphical resources that can be used by clients,
without allocating any graphics memory in the client.
+ \note The texture sharing functionality is considered experimental and
+ currently unsupported in Qt 6.
+
\section2 Usage
This module is imported like this:
diff --git a/src/imports/texture-sharing-extension/qmldir b/src/imports/texture-sharing-extension/qmldir
deleted file mode 100644
index c66f29bc1..000000000
--- a/src/imports/texture-sharing-extension/qmldir
+++ /dev/null
@@ -1,4 +0,0 @@
-module QtWayland.Compositor.TextureSharingExtension
-plugin qwaylandtexturesharingextension
-classname QWaylandTextureSharingExtensionPlugin
-typeinfo plugins.qmltypes
diff --git a/src/imports/texture-sharing-extension/texture-sharing-extension.pro b/src/imports/texture-sharing-extension/texture-sharing-extension.pro
deleted file mode 100644
index 68a8cf757..000000000
--- a/src/imports/texture-sharing-extension/texture-sharing-extension.pro
+++ /dev/null
@@ -1,11 +0,0 @@
-CXX_MODULE = qml
-TARGET = qwaylandtexturesharingextension
-TARGETPATH = QtWayland/Compositor/TextureSharingExtension
-IMPORT_VERSION = 1.$$QT_MINOR_VERSION
-
-SOURCES += \
- plugin.cpp
-
-QT += quick-private qml gui-private core-private waylandcompositor waylandcompositor-private
-
-load(qml_plugin)