summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-06-25 12:39:08 +0200
committerMichal Klocek <michal.klocek@qt.io>2021-06-29 17:33:03 +0200
commit7237c81bf20571fac2f898e7e29e7be386e3270a (patch)
treea281881d8e4b8139604056f9073b21afbf9d2308 /CMakeLists.txt
parent82769967d385c3037cfe2decb6687abdf23035f9 (diff)
Add implicit dependencies in case of topLevel build
Pick-to: 6.2 Change-Id: Ic7a4096d06b05a62a01565d6e7aceac12dc73def Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a3ff75cb..b5fdebc0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,6 +151,11 @@ externalproject_add(libs
COMMAND ${CMAKE_COMMAND} -E remove_directory ../mkspecs
)
+# required for topLevel build
+add_implicit_dependencies(libs Core Gui Widgets Network OpenGL
+ OpenGLWidgets Quick QuickWidgets Qml PrintSupport WebChannel Positioning
+)
+
# Ensure the libs project is reconfigured if the root project is reconfigured, so that the
# correct CMake and qmake support files are used when building examples, rather than
# using the incomplete support files created by the root project.