summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-06-06 19:18:15 +0200
committerCraig Scott <craig.scott@qt.io>2021-06-07 18:34:43 +1000
commit790da1696930d30b6009b185dd2e247e22d4bf1b (patch)
treebe0e2338bd5d9602d5c42508c785a0ce320d3319 /CMakeLists.txt
parentc2f087800d247d41fe4fa4f737b5322ae22c9e9d (diff)
Replace calls to obsolete cmake functions with modern alternative
Change-Id: I5674d887a73a6a693d1babc416470c9873491eb3 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb1050109..3b4f06d7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,9 @@ project(QtWebEngineRepoSuperBuild
LANGUAGES CXX C
)
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
# Make sure we use the fixed BASE argument of qt_add_resource.
set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)