summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-06-04 17:42:09 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-06-15 10:53:32 +0000
commit8d23c52719a23dea77a75a959ca3462e38de259c (patch)
treec198410a3e8fba921b8ee589fba08071d0fe0866 /CMakeLists.txt
parente0979612a57d0a71c2b4f5d646547b5a5f6ab99c (diff)
CMake: Ensure libs project is reconfigured when the root project is
To ensure that correct CMake and qmake support files are used when building examples. Change-Id: Ic52ee7f7153877071ab3883fd436ad888f90680d Reviewed-by: Michal Klocek <michal.klocek@qt.io> (cherry picked from commit f04bc6833c01efc0fb37d6f6c31c6fa427087664) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ecea7f0fe..dabf07b3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,6 +154,11 @@ externalproject_add(libs
COMMAND ${CMAKE_COMMAND} -E remove_directory ../mkspecs
)
+# Ensure the libs project is reconfigured if the root project is reconfigured, so that the
+# correct CMake and qmake support files are used when building examples, rather than
+# using the incomplete support files created by the root project.
+qt_internal_add_external_project_dependency_to_root_project(libs)
+
if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
externalproject_add(qtwebengine_examples
SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/examples