summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-03-05 09:54:20 +0100
committerMichal Klocek <michal.klocek@qt.io>2021-05-22 14:10:13 +0200
commitbd2e13ef62510b547cc07729cfa024a75987bee2 (patch)
tree29710c63c3fb8b73d833fbd6e6f8416cb8474fb1 /CMakeLists.txt
parent97dcbd4019456b9a1c567faddb0521b7505d80fc (diff)
Bump the minimum required cmake version to 3.19
QtWebEngine requires support of TARGET_PROPERTY for genex in gn template generation to dump all compilation flags. This is supported since version 3.19, set examples to 3.16 as rest of the qt. Task-number: QTBUG-91760 Change-Id: Ifa5903c8c6efcb160db05baf1e18c865b48bcf39 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c7b24a45..876db610e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.18.0)
+cmake_minimum_required(VERSION 3.19)
include(.cmake.conf)
include(ExternalProject)