summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-09-13 08:37:24 +0200
committerMichal Klocek <michal.klocek@qt.io>2021-10-07 08:01:01 +0200
commitc97895e0843db3fa9ac3b029262dc86e1504849c (patch)
tree68de5bfa4b02dfc58409b7aa585396329a7ae1e4 /CMakeLists.txt
parent7c35fa991f0e523e6d0901109caceed5aaac3658 (diff)
Add matrix builds
Since coin does not support doing matrix projects, add primitive way to automate features builds. Add self build launcher in form of external projects to do few builds one after the other which test some of our features. These are just compilation tests and could also run in coin as scheduled build. Usage: /path/to/qt-cmake-private /path/to/webenginesources -DMATRIX_BUILD=ON Created currently builds: * webengine_extensions-OFF * webengine_printing_and_pdf-OFF * webengine_proprietary_codecs-ON * webengine_spellchecker-OFF * webengine_webrtc-OFF * qtwebengine_build-OFF Pick-to: 6.2 Change-Id: Ie1bbc2cf9b01cb2e5089832d8f1cd6171e31b6fe Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4202eaeec..35248b6f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,5 +16,16 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG QUIET OPTIONAL_COMPONENTS
Gui Widgets Network OpenGL Quick Qml PrintSupport
WebChannel Positioning QuickControls2 Test QuickWidgets QuickTest WebSockets Designer
)
+
+if(MATRIX_BUILD AND NOT MATRIX_SUBBUILD AND NOT QT_SUPERBUILD)
+ add_build(webengine_webrtc OFF)
+ add_build(webengine_proprietary_codecs ON)
+ add_build(webengine_printing_and_pdf OFF)
+ add_build(webengine_extensions OFF)
+ add_build(webengine_spellchecker OFF)
+ add_build(qtwebengine_build OFF)
+ return()
+endif()
+
set(WEBENGINE_MODULE_BUILD TRUE)
qt_build_repo()