summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-05-06 09:03:58 +0200
committerMichal Klocek <michal.klocek@qt.io>2021-05-22 14:10:49 +0200
commitcf49605c1b93ecdbaa0fa086181beb2c05001747 (patch)
tree90d9f7e47bc75b782c69204e49fc148ae1c9cd55 /CMakeLists.txt
parent6f4294f845f825b2cadef7f2c8125462d8950b61 (diff)
Fix build of qmake examples on coin
Coin compiles examples with qmake during cmake build, unfortunately this fails to have proper includes. The reason is that during the build qt-cmake creates dummy mkspecs files even for targets excluded from 'all'. (targets we use for genex execute). These files later are sucked by qmake instead of installed pri files since the source tree is tainted on coin due to doing in-source builds. Add a workaround for now and make sure dummy mkspecs are removed. Task-number: QTBUG-93694 Change-Id: If288809b336055a170baa82b7a75d8e9ae46f988 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d97799b88..75f019f38 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,6 +133,11 @@ externalproject_add(libs
BUILD_COMMAND ${CMAKE_COMMAND} -E echo "Starting $<CONFIG> build"
${coinBug699}
COMMAND ${CMAKE_COMMAND} -E echo "$<CONFIG> build complete"
+ # TODO: this is aworkaround for broken qt_lib_webengine*.pri files,
+ # coin does the in-source build and later calls qmake to build examples
+ # and this leftover file gets sucked instead of install or src/mkspecs,
+ # simply remove it, we need to implment a dry run in qt base to fix it.
+ COMMAND ${CMAKE_COMMAND} -E remove_directory ../mkspecs
)
if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)