summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2021-05-25 12:37:15 +0200
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2021-05-25 16:40:56 +0200
commitd53f7fcc52ab8f10ff406d5ae3bd00deeab969d8 (patch)
treedacd03ab1a3160162fc64083c267420ddaa27aab /CMakeLists.txt
parentf71472d37e93a54be78c91ae1770204a4de273ea (diff)
Add support for top-level configs and developer builds
Guess a toolchain link for top-level builds. Copy the resources to their final destinations, and search for the helper process where it is build in this config. Change-Id: Ie9e829c19d42dddb85df188e48ec269f85268ed4 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 75f019f38..203cd1c6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,6 +101,13 @@ get_filename_component(WEBENGINE_ROOT_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}" R
get_qt_features(featureList webengine)
get_qt_features(featureList qtwebengine)
+if(NOT DEFINED CMAKE_TOOLCHAIN_FILE)
+ set(CMAKE_TOOLCHAIN_FILE "${CMAKE_BINARY_DIR}/qtbase/lib/cmake/Qt6/qt.toolchain.cmake")
+ list(APPEND libsCmakeArgs
+ "-DCMAKE_INSTALL_PREFIX=${CMAKE_INSTALL_PREFIX}"
+ )
+endif()
+
list(TRANSFORM featureList PREPEND "-D")
list(APPEND libsCmakeArgs
"-DCMAKE_TOOLCHAIN_FILE=${CMAKE_TOOLCHAIN_FILE}"