summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Varga <pvarga@inf.u-szeged.hu>2021-06-08 08:43:41 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-06-10 23:20:07 +0000
commitd627842e98c1cbaec0123566dc1af7b6018e5dc1 (patch)
tree713c46559e37d7b8b499abc82a82174264f3263b /CMakeLists.txt
parent3917128b131b1c69bd78e99aec14abf477567b05 (diff)
Fix "examples" and "tests" target name collisions
Fixes: QTBUG-94333 Change-Id: I1e9b4c3f042dc370441e062288f5f9689d31c091 Reviewed-by: Michal Klocek <michal.klocek@qt.io> (cherry picked from commit b8804bf868c9f9b18a8b1caa9f512659113ddb98) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b4f06d7e..63d227fc4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,7 +154,7 @@ externalproject_add(libs
)
if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
- externalproject_add(examples
+ externalproject_add(qtwebengine_examples
SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/examples
BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/examples
PREFIX examples
@@ -163,7 +163,7 @@ if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
CMAKE_ARGS -DCMAKE_TOOLCHAIN_FILE=${CMAKE_TOOLCHAIN_FILE}
"${featureList}"
)
- externalproject_add_stepdependencies(examples install libs)
+ externalproject_add_stepdependencies(qtwebengine_examples install libs)
endif()
if(FORCE_TEST_RUN OR QT_BUILD_TESTS)
@@ -172,7 +172,7 @@ if(FORCE_TEST_RUN OR QT_BUILD_TESTS)
if(FORCE_TEST_RUN)
set(testRunCommand TEST_COMMAND ctest)
endif()
- externalproject_add(tests
+ externalproject_add(qtwebengine_tests
SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/tests
BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/tests
PREFIX tests
@@ -184,9 +184,9 @@ if(FORCE_TEST_RUN OR QT_BUILD_TESTS)
INSTALL_COMMAND ""
${testRunCommand}
)
- externalproject_add_stepdependencies(tests install libs)
+ externalproject_add_stepdependencies(qtwebengine_tests install libs)
if(QT_BUILD_EXAMPLES AND BUILD_SHARED_LIBS)
- externalproject_add_stepdependencies(tests install examples)
+ externalproject_add_stepdependencies(qtwebengine_tests install qtwebengine_examples)
endif()
endif()