summaryrefslogtreecommitdiffstats
path: root/src/core/api/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2023-03-29 14:20:33 +0200
committerMichal Klocek <michal.klocek@qt.io>2023-03-30 01:17:04 +0200
commite368689df5566462ceea28c06803f9a0abf91cc5 (patch)
tree51f46594ccb747ddb74f27cc4660d3151412e5c5 /src/core/api/CMakeLists.txt
parent67eb9e151f75ff1fc570c27ede7868f40ed299ff (diff)
Require gn for generating docs
Make sure gn is build before doc target, otherwise parallel top level build might not succeed. As configure runs the gn binary is not compiled so use scripting mode to execute gn call during build time. Pick-to: 6.5 Task-number: QTBUG-108751 Change-Id: I7e851de90e2a3ec52f5259d51f677b23d8245bcb Reviewed-by: Michael BrĂ¼ning <michael.bruning@qt.io>
Diffstat (limited to 'src/core/api/CMakeLists.txt')
-rw-r--r--src/core/api/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/core/api/CMakeLists.txt b/src/core/api/CMakeLists.txt
index 86dfb9910..ba973fd32 100644
--- a/src/core/api/CMakeLists.txt
+++ b/src/core/api/CMakeLists.txt
@@ -95,6 +95,7 @@ add_code_attributions_target(
ENTRY_TEMPLATE ../doc/about_credits_entry.tmpl
BUILDDIR ${buildDir}/${config}/${arch}
)
+add_dependencies(generate_chromium_attributions run_core_GnDone)
add_dependencies(docs generate_chromium_attributions)
##