summaryrefslogtreecommitdiffstats
path: root/tests/auto/core/qtversion/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2023-01-05 10:54:33 +0100
committerMichal Klocek <michal.klocek@qt.io>2023-08-11 20:43:03 +0200
commita748cb9183143b76cad1e940220dcabf25475493 (patch)
treeed5aa1f51c0034d4ea97956b5af7a49b32c6d103 /tests/auto/core/qtversion/CMakeLists.txt
parenta63e5b1f0e4b65c5ce59e705129ab368677a94a8 (diff)
Add initial internal version page
We kept urls in examples to point to company website. However this site is heavy to load and moreover it changes overtime leaving example screenshots obsolete. Introduce internal qt version web ui page which will be default page for examples and which displays basic information and can work offline. For start show version info and command line options for chrome://qt Pick-to: 6.6 Change-Id: I0271ce6e7b152efe4942a6240b0c74ba382d5fcc Reviewed-by: Michael BrĂ¼ning <michael.bruning@qt.io>
Diffstat (limited to 'tests/auto/core/qtversion/CMakeLists.txt')
-rw-r--r--tests/auto/core/qtversion/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/auto/core/qtversion/CMakeLists.txt b/tests/auto/core/qtversion/CMakeLists.txt
new file mode 100644
index 000000000..9a5e89266
--- /dev/null
+++ b/tests/auto/core/qtversion/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_test(tst_qtversion
+ SOURCES
+ tst_qtversion.cpp
+ LIBRARIES
+ Qt::WebEngineCore
+)
+