summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 000000000..e863dafaf
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+
+qt_examples_build_begin(EXTERNAL_BUILD)
+if(NOT CMAKE_CROSSCOMPILING) #QTBUG-86533
+ if(TARGET Qt::WebEngineCore)
+ add_subdirectory(webenginequick)
+ endif()
+ if(TARGET Qt::WebEngineWidgets)
+ add_subdirectory(webenginewidgets)
+ endif()
+ if(TARGET Qt::Pdf)
+ add_subdirectory(pdf)
+ endif()
+ if(TARGET Qt::PdfWidgets)
+ add_subdirectory(pdfwidgets)
+ endif()
+endif()
+qt_examples_build_end()