summaryrefslogtreecommitdiffstats
path: root/examples/webenginewidgets/videoplayer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/webenginewidgets/videoplayer/CMakeLists.txt')
-rw-r--r--examples/webenginewidgets/videoplayer/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/examples/webenginewidgets/videoplayer/CMakeLists.txt b/examples/webenginewidgets/videoplayer/CMakeLists.txt
new file mode 100644
index 000000000..0aff069d7
--- /dev/null
+++ b/examples/webenginewidgets/videoplayer/CMakeLists.txt
@@ -0,0 +1,53 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(videoplayer LANGUAGES CXX)
+
+set(CMAKE_AUTOMOC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/webenginewidgets/videoplayer")
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui WebEngineWidgets)
+
+qt_add_executable(videoplayer
+ fullscreennotification.cpp fullscreennotification.h
+ fullscreenwindow.cpp fullscreenwindow.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+)
+
+set_target_properties(videoplayer PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(videoplayer PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::WebEngineWidgets
+)
+
+# Resources:
+set(videoplayer_resource_files
+ "data/index.html"
+)
+
+qt_add_resources(videoplayer "videoplayer"
+ PREFIX
+ "/"
+ BASE
+ "data"
+ FILES
+ ${videoplayer_resource_files}
+)
+
+install(TARGETS videoplayer
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)