summaryrefslogtreecommitdiffstats
path: root/src/core/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/api/CMakeLists.txt')
-rw-r--r--src/core/api/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/core/api/CMakeLists.txt b/src/core/api/CMakeLists.txt
index f2ceb2dfd..2a06baec6 100644
--- a/src/core/api/CMakeLists.txt
+++ b/src/core/api/CMakeLists.txt
@@ -19,6 +19,7 @@ qt_internal_add_module(WebEngineCore
qwebenginedownloadrequest.cpp qwebenginedownloadrequest.h qwebenginedownloadrequest_p.h
qwebenginefilesystemaccessrequest.cpp qwebenginefilesystemaccessrequest.h
qwebenginefindtextresult.cpp qwebenginefindtextresult.h
+ qwebengineframe.cpp qwebengineframe.h
qwebenginefullscreenrequest.cpp qwebenginefullscreenrequest.h
qwebenginehistory.cpp qwebenginehistory.h qwebenginehistory_p.h
qwebenginehttprequest.cpp qwebenginehttprequest.h
@@ -28,6 +29,7 @@ qt_internal_add_module(WebEngineCore
qwebenginenewwindowrequest.cpp qwebenginenewwindowrequest.h qwebenginenewwindowrequest_p.h
qwebenginenotification.cpp qwebenginenotification.h
qwebenginepage.cpp qwebenginepage.h qwebenginepage_p.h
+ qwebenginepermission.cpp qwebenginepermission.h qwebenginepermission_p.h
qwebengineprofile.cpp qwebengineprofile.h qwebengineprofile_p.h
qwebenginequotarequest.cpp qwebenginequotarequest.h
qwebengineregisterprotocolhandlerrequest.cpp qwebengineregisterprotocolhandlerrequest.h
@@ -49,6 +51,7 @@ qt_internal_add_module(WebEngineCore
../../3rdparty/chromium/third_party/abseil-cpp
../../3rdparty/chromium/third_party/perfetto/include
../../3rdparty/chromium/third_party/boringssl/src/include
+ ../../3rdparty/chromium/base/allocator/partition_allocator/src
LIBRARIES
Qt::CorePrivate
Qt::GuiPrivate
@@ -65,10 +68,13 @@ qt_internal_add_module(WebEngineCore
set_target_properties(WebEngineCore PROPERTIES QTWEBENGINEPROCESS_NAME ${qtWebEngineProcessName})
set_target_properties(WebEngineCore PROPERTIES CXX_STANDARD 20)
-
# Chromium included headers are not clean
qt_skip_warnings_are_errors(WebEngineCore)
+if(MSVC AND NOT CLANG)
+ target_compile_options(WebEngineCore PRIVATE "/Zc:preprocessor")
+endif()
+
if(CLANG OR GCC)
target_compile_options(WebEngineCore PRIVATE
"-Wno-unused-parameter"