summaryrefslogtreecommitdiffstats
path: root/src/host/config.tests/hostcompiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/host/config.tests/hostcompiler/CMakeLists.txt')
-rw-r--r--src/host/config.tests/hostcompiler/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/host/config.tests/hostcompiler/CMakeLists.txt b/src/host/config.tests/hostcompiler/CMakeLists.txt
new file mode 100644
index 000000000..f36886d0a
--- /dev/null
+++ b/src/host/config.tests/hostcompiler/CMakeLists.txt
@@ -0,0 +1,11 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(arch LANGUAGES CXX)
+
+add_executable(host_compiler_test)
+set_property(TARGET host_compiler_test PROPERTY MACOSX_BUNDLE FALSE)
+target_sources(host_compiler_test PRIVATE main.cpp)
+target_compile_options(host_compiler_test PRIVATE -m32)
+target_link_options(host_compiler_test PRIVATE -m32)