summaryrefslogtreecommitdiffstats
path: root/src/pdfquick/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pdfquick/CMakeLists.txt')
-rw-r--r--src/pdfquick/CMakeLists.txt41
1 files changed, 16 insertions, 25 deletions
diff --git a/src/pdfquick/CMakeLists.txt b/src/pdfquick/CMakeLists.txt
index 5bbe66959..d57ce04aa 100644
--- a/src/pdfquick/CMakeLists.txt
+++ b/src/pdfquick/CMakeLists.txt
@@ -1,32 +1,32 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Core Gui Qml Quick)
set(qml_files
-# TODO:
-# "qml/+material/PdfStyle.qml"
-# "qml/+universal/PdfStyle.qml"
- "qml/PdfMultiPageView.qml"
- "qml/PdfPageView.qml"
- "qml/PdfScrollablePageView.qml"
- "qml/PdfStyle.qml"
+ "+Material/PdfStyle.qml"
+ "+Universal/PdfStyle.qml"
+ "PdfLinkDelegate.qml"
+ "PdfMultiPageView.qml"
+ "PdfPageView.qml"
+ "PdfScrollablePageView.qml"
+ "PdfStyle.qml"
)
qt_internal_add_qml_module(PdfQuick
URI "QtQuick.Pdf"
VERSION "${PROJECT_VERSION}"
- CLASS_NAME QtQuick2PdfPlugin
- NO_GENERATE_PLUGIN_SOURCE
- NO_PLUGIN_OPTIONAL
- NO_GENERATE_QMLTYPES
- PLUGIN_TARGET qtpdfquickplugin
+ PAST_MAJOR_VERSIONS 5
QML_FILES ${qml_files}
- DEPENDENCIES QtQuickControls2
+ DEPENDENCIES QtQuick/auto
SOURCES
+ qquickpdfbookmarkmodel.cpp qquickpdfbookmarkmodel_p.h
qquickpdfdocument.cpp qquickpdfdocument_p.h
qquickpdflinkmodel.cpp qquickpdflinkmodel_p.h
- qquickpdfnavigationstack.cpp qquickpdfnavigationstack_p.h
+ qquickpdfpagenavigator.cpp qquickpdfpagenavigator_p.h
+ qquickpdfpageimage.cpp qquickpdfpageimage_p.h
qquickpdfsearchmodel.cpp qquickpdfsearchmodel_p.h
qquickpdfselection.cpp qquickpdfselection_p.h
- qquicktableviewextra.cpp qquicktableviewextra_p.h
qtpdfquickglobal_p.h
INCLUDE_DIRECTORIES
../3rdparty/chromium
@@ -36,15 +36,6 @@ qt_internal_add_qml_module(PdfQuick
Qt::Core
Qt::Gui
Qt::Qml
+ NO_GENERATE_CPP_EXPORTS
)
-qt_internal_extend_target(qtpdfquickplugin
- SOURCES
- plugin.cpp
- LIBRARIES
- Qt::CorePrivate
- Qt::PdfQuickPrivate
-)
-
-
-