summaryrefslogtreecommitdiffstats
path: root/src/pdfquick/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pdfquick/CMakeLists.txt')
-rw-r--r--src/pdfquick/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/pdfquick/CMakeLists.txt b/src/pdfquick/CMakeLists.txt
index b29f57aeb..d57ce04aa 100644
--- a/src/pdfquick/CMakeLists.txt
+++ b/src/pdfquick/CMakeLists.txt
@@ -1,8 +1,12 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS Core Gui Qml Quick)
set(qml_files
"+Material/PdfStyle.qml"
"+Universal/PdfStyle.qml"
+ "PdfLinkDelegate.qml"
"PdfMultiPageView.qml"
"PdfPageView.qml"
"PdfScrollablePageView.qml"
@@ -19,7 +23,7 @@ qt_internal_add_qml_module(PdfQuick
qquickpdfbookmarkmodel.cpp qquickpdfbookmarkmodel_p.h
qquickpdfdocument.cpp qquickpdfdocument_p.h
qquickpdflinkmodel.cpp qquickpdflinkmodel_p.h
- qquickpdfnavigationstack.cpp qquickpdfnavigationstack_p.h
+ qquickpdfpagenavigator.cpp qquickpdfpagenavigator_p.h
qquickpdfpageimage.cpp qquickpdfpageimage_p.h
qquickpdfsearchmodel.cpp qquickpdfsearchmodel_p.h
qquickpdfselection.cpp qquickpdfselection_p.h
@@ -32,5 +36,6 @@ qt_internal_add_qml_module(PdfQuick
Qt::Core
Qt::Gui
Qt::Qml
+ NO_GENERATE_CPP_EXPORTS
)