summaryrefslogtreecommitdiffstats
path: root/src/webenginequick/testsupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/webenginequick/testsupport/CMakeLists.txt')
-rw-r--r--src/webenginequick/testsupport/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/webenginequick/testsupport/CMakeLists.txt b/src/webenginequick/testsupport/CMakeLists.txt
new file mode 100644
index 000000000..57805a450
--- /dev/null
+++ b/src/webenginequick/testsupport/CMakeLists.txt
@@ -0,0 +1,17 @@
+qt_internal_add_qml_module(qtwebenginetestsupportplugin
+ URI "QtWebEngine.testsupport"
+ VERSION "${PROJECT_VERSION}"
+ CLASS_NAME QtWebEngineTestSupportPlugin
+ PLUGIN_TARGET qtwebenginetestsupportplugin
+ NO_GENERATE_PLUGIN_SOURCE
+ NO_PLUGIN_OPTIONAL
+ NO_GENERATE_QMLTYPES
+ INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ Qt::Qml
+ Qt::WebEngineQuickPrivate
+)
+make_install_only(qtwebenginetestsupportplugin)