summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt23
1 files changed, 13 insertions, 10 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 2227e6e46..1b0ff3e9d 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,17 +1,20 @@
-if(QT_FEATURE_qtwebengine_build
- OR (QT_BUILD_STANDALONE_TESTS AND TARGET Qt::WebEngineCore))
- add_subdirectory(core)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+add_subdirectory(cmake)
+if(TARGET Qt::WebEngineCore)
add_subdirectory(httpserver)
add_subdirectory(util)
+ add_subdirectory(core)
endif()
-if(QT_FEATURE_qtwebengine_quick_build
- OR (QT_BUILD_STANDALONE_TESTS AND TARGET Qt::WebEngineQuick))
+if(TARGET Qt::WebEngineQuick)
add_subdirectory(quick)
endif()
-if(QT_FEATURE_qtwebengine_widgets_build
- OR (QT_BUILD_STANDALONE_TESTS AND TARGET Qt::WebEngineWidgets))
+if(TARGET Qt::WebEngineWidgets)
add_subdirectory(widgets)
endif()
-#if(QT_FEATURE_build_qtpdf AND QT_FEATURE_webengine_qtpdf_support)
-# add_subdirectory(pdf)
-#endif()
+if(TARGET Qt::Pdf)
+ add_subdirectory(pdf)
+endif()
+if(TARGET Qt::PdfQuick)
+ add_subdirectory(pdfquick)
+endif()