summaryrefslogtreecommitdiffstats
path: root/tests/auto/pdf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/pdf/CMakeLists.txt')
-rw-r--r--tests/auto/pdf/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/auto/pdf/CMakeLists.txt b/tests/auto/pdf/CMakeLists.txt
new file mode 100644
index 000000000..205bd24d0
--- /dev/null
+++ b/tests/auto/pdf/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+add_subdirectory(qpdfbookmarkmodel)
+if (TARGET Qt::PdfWidgets)
+ add_subdirectory(qpdfpagenavigator)
+endif()
+add_subdirectory(qpdfpagerenderer)
+add_subdirectory(qpdfsearchmodel)
+if(TARGET Qt::PrintSupport)
+ add_subdirectory(qpdfdocument)
+endif()