summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/origins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/origins/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/origins/CMakeLists.txt45
1 files changed, 0 insertions, 45 deletions
diff --git a/tests/auto/widgets/origins/CMakeLists.txt b/tests/auto/widgets/origins/CMakeLists.txt
deleted file mode 100644
index ca7a6a249..000000000
--- a/tests/auto/widgets/origins/CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
-include(../../httpserver/httpserver.cmake)
-include(../../util/util.cmake)
-
-qt_internal_add_test(tst_origins
- SOURCES
- tst_origins.cpp
- LIBRARIES
- Qt::WebEngineWidgets
- Test::HttpServer
- Test::Util
-)
-
-set(tst_origins_resource_files
- "resources/createObjectURL.html"
- "resources/dedicatedWorker.html"
- "resources/dedicatedWorker.js"
- "resources/mixedSchemes.html"
- "resources/mixedSchemesWithCsp.html"
- "resources/mixedSchemes_frame.html"
- "resources/mixedXHR.html"
- "resources/mixedXHR.txt"
- "resources/serviceWorker.html"
- "resources/serviceWorker.js"
- "resources/sharedWorker.html"
- "resources/sharedWorker.js"
- "resources/subdir/frame2.html"
- "resources/subdir/index.html"
- "resources/subdir_frame1.html"
- "resources/viewSource.html"
- "resources/websocket.html"
-)
-
-qt_internal_add_resource(tst_origins "tst_origins"
- PREFIX
- "/"
- FILES
- ${tst_origins_resource_files}
-)
-
-qt_internal_extend_target(tst_origins CONDITION QT_FEATURE_webengine_webchannel AND TARGET Qt::WebSockets
- DEFINES
- WEBSOCKETS
- LIBRARIES
- Qt::WebSockets
-)