summaryrefslogtreecommitdiffstats
path: root/tests/manual/quick/touchbrowser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/quick/touchbrowser/CMakeLists.txt')
-rw-r--r--tests/manual/quick/touchbrowser/CMakeLists.txt39
1 files changed, 16 insertions, 23 deletions
diff --git a/tests/manual/quick/touchbrowser/CMakeLists.txt b/tests/manual/quick/touchbrowser/CMakeLists.txt
index c211ba8e6..0d3275e58 100644
--- a/tests/manual/quick/touchbrowser/CMakeLists.txt
+++ b/tests/manual/quick/touchbrowser/CMakeLists.txt
@@ -1,38 +1,31 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
- cmake_minimum_required(VERSION 3.16)
+ cmake_minimum_required(VERSION 3.19)
project(touchbrowser LANGUAGES CXX)
find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
endif()
-if(NOT CMAKE_CROSSCOMPILING)
- add_definitions(-DDESKTOP_BUILD)
- set(SOURCES "touchmockingapplication.cpp")
-endif()
+set(CMAKE_AUTORCC ON)
+set(TOUCHMOCKING_DIR "../../touchmocking")
+
+include_directories(${TOUCHMOCKING_DIR})
+add_definitions(-DQUICK_TOUCHBROWSER)
-qt_internal_add_manual_test(touchbrowser
+qt_internal_add_manual_test(touchbrowser-quick
GUI
SOURCES
main.cpp
- utils.h
- ${SOURCES}
- PUBLIC_LIBRARIES
- Qt::GuiPrivate
+ resources.qrc
+ ${TOUCHMOCKING_DIR}/touchmockingapplication.cpp
+ ${TOUCHMOCKING_DIR}/touchmockingapplication.h
+ ${TOUCHMOCKING_DIR}/utils.h
+ LIBRARIES
+ Qt::Core
Qt::Quick
Qt::WebEngineQuick
ENABLE_AUTOGEN_TOOLS
moc
)
-set(touchbrowser_resource_files
- "AddressBar.qml"
- "main.qml"
- "MockTouchPoint.qml"
- "touchpoint.png"
-)
-
-qt_add_resources(touchbrowser "touchbrowser"
- PREFIX
- "/"
- FILES
- ${touchbrowser_resource_files}
-)