summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-05-12 07:53:00 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-06-01 05:16:21 +0000
commit29f9f199b3d85eb884d2d5665df29f5e7a5d994f (patch)
tree4b6defb5f1337040b4ce796fa3ba53bd08c87c23
parent3b0132827fd5a2bcd6c196bdeb0975851b230b1e (diff)
Move all toradex related recipes from meta-boot2qt
Add support for Toradex boards to separate layer that can be used together with meta-boot2qt. Change-Id: I15797117446406e3419de829b6e05e6b47751ed3 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--COPYING.MIT17
-rw-r--r--README23
-rw-r--r--conf/bblayers.conf.sample26
-rw-r--r--conf/conf-notes.txt17
-rw-r--r--conf/distro/include/b2qt.inc39
-rw-r--r--conf/layer.conf15
-rw-r--r--recipes-bsp/tezi-metadata/files/Built_with_Qt.pngbin0 -> 1871 bytes
-rw-r--r--recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT75
-rw-r--r--recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend15
-rw-r--r--recipes-core/base-files/base-files_%.bbappend6
-rw-r--r--recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bbappend7
-rw-r--r--recipes-kernel/linux/linux-toradex_5.%.bbappend15
-rw-r--r--recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch26
-rw-r--r--recipes-multimedia/alsa-utils/alsa-utils_%.bbappend3
-rw-r--r--recipes-qt/boot2qt-addons/qbsp-readme.bbappend1
-rw-r--r--recipes-qt/boot2qt-addons/qbsp-readme/README66
-rw-r--r--recipes-qt/boot2qt-addons/qbsp-readme/mx8-generic-bsp/README52
17 files changed, 403 insertions, 0 deletions
diff --git a/COPYING.MIT b/COPYING.MIT
new file mode 100644
index 0000000..fb950dc
--- /dev/null
+++ b/COPYING.MIT
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/README b/README
new file mode 100644
index 0000000..2dd167f
--- /dev/null
+++ b/README
@@ -0,0 +1,23 @@
+Boot2Qt BSP layer for Toradex boards
+===============================
+
+This layer provides additional configuration and recipe appends to support
+Boot2Qt on Toradex Boards.
+
+How to use this layer
+---------------------
+
+Using this layer requires Google's repo tool to be installed, you can install
+it from package manager (apt install repo) or download with:
+
+ curl https://storage.googleapis.com/git-repo-downloads/repo -o repo
+ chmod a+x repo
+
+
+After installing the repo tool, run following commands to initialize the build environment.
+
+ repo init -u git://code.qt.io/yocto/boot2qt-manifest -m toradex/dev.xml
+ repo sync
+
+ export MACHINE=apalis-imx8
+ . ./setup-environment.sh
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
new file mode 100644
index 0000000..4ca9c5b
--- /dev/null
+++ b/conf/bblayers.conf.sample
@@ -0,0 +1,26 @@
+# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+POKY_BBLAYERS_CONF_VERSION = "2"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE')) + '/../..')}"
+
+BBLAYERS ?= " \
+ ${BSPDIR}/sources/poky/meta \
+ ${BSPDIR}/sources/poky/meta-poky \
+ ${BSPDIR}/sources/meta-freescale \
+ ${BSPDIR}/sources/meta-freescale-3rdparty \
+ ${BSPDIR}/sources/meta-toradex-bsp-common \
+ ${BSPDIR}/sources/meta-toradex-nxp \
+ ${BSPDIR}/sources/meta-openembedded/meta-oe \
+ ${BSPDIR}/sources/meta-openembedded/meta-python \
+ ${BSPDIR}/sources/meta-openembedded/meta-networking \
+ ${BSPDIR}/sources/meta-openembedded/meta-initramfs \
+ ${BSPDIR}/sources/meta-openembedded/meta-multimedia \
+ ${BSPDIR}/sources/meta-boot2qt/meta-boot2qt \
+ ${BSPDIR}/sources/meta-boot2qt/meta-boot2qt-distro \
+ ${BSPDIR}/sources/meta-boot2qt-toradex \
+ ${BSPDIR}/sources/meta-mingw \
+ ${BSPDIR}/sources/meta-qt6 \
+ "
diff --git a/conf/conf-notes.txt b/conf/conf-notes.txt
new file mode 100644
index 0000000..5446d4f
--- /dev/null
+++ b/conf/conf-notes.txt
@@ -0,0 +1,17 @@
+
+### Shell environment set up for builds. ###
+
+You can now run 'bitbake <target>'
+
+Common targets are:
+ b2qt-embedded-qt6-image
+ meta-toolchain-b2qt-embedded-qt6-sdk
+
+QBSP target is:
+ meta-b2qt-embedded-qbsp
+
+For creating toolchain or QBSP for Windows, set environment variable before running bitbake:
+ SDKMACHINE=x86_64-mingw32
+
+For more information about Boot to Qt, see https://doc.qt.io/Boot2Qt
+
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
new file mode 100644
index 0000000..c5da885
--- /dev/null
+++ b/conf/distro/include/b2qt.inc
@@ -0,0 +1,39 @@
+# include file from meta-toradex-nxp
+include conf/machine/include/${MACHINE}.inc
+
+IMAGE_CLASSES += "image_type_tezi_b2qt"
+
+QBSP_IMAGE_CONTENT += "\
+ ${IMAGE_LINK_NAME}.tezi.tar \
+"
+
+BBMASK += "\
+ meta-toradex-nxp/backports \
+ meta-toradex-nxp/recipes-bsp/u-boot/u-boot-tools_%.bbappend \
+"
+
+DEPLOY_CONF_NAME = "Toradex ${MACHINE_NAME}"
+DEPLOY_CONF_NAME:apalis-imx6 = "Toradex Apalis iMX6"
+DEPLOY_CONF_NAME:apalis-imx8 = "Toradex Apalis iMX8"
+DEPLOY_CONF_NAME:colibri-imx6 = "Toradex Colibri iMX6"
+DEPLOY_CONF_NAME:colibri-imx6ull = "Toradex Colibri iMX6 ULL"
+DEPLOY_CONF_NAME:colibri-imx6ull-emmc = "Toradex Colibri iMX6 ULL eMMC"
+DEPLOY_CONF_NAME:colibri-imx7 = "Toradex Colibri iMX7"
+DEPLOY_CONF_NAME:colibri-imx7-emmc = "Toradex Colibri iMX7 eMMC"
+DEPLOY_CONF_NAME:colibri-imx8x = "Toradex Colibri iMX8X"
+DEPLOY_CONF_NAME:verdin-imx8mm = "Toradex Verdin iMX8M Mini"
+DEPLOY_CONF_NAME:verdin-imx8mp = "Toradex Verdin iMX8M Plus"
+
+# Suitable DRI device
+DRI_DEVICE:apalis-imx6 = "card1"
+DRI_DEVICE:colibri-imx6 = "card1"
+DRI_DEVICE:colibri-imx7-emmc = "card0"
+DRI_DEVICE:apalis-imx8 = "card1"
+DRI_DEVICE:apalis-imx8x = "card0"
+DRI_DEVICE:colibri-imx8x = "card1"
+DRI_DEVICE:colibri-imx8x-v10b = "card1"
+DRI_DEVICE:verdin-imx8mm = "card0"
+DRI_DEVICE:verdin-imx8mp = "card0"
+
+# remove support for 256MB version colibri-imx6ull in tezi image, since image will be too large for it.
+TORADEX_PRODUCT_IDS:remove:colibri-imx6ull = "0036"
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..1f5b412
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,15 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend \
+ "
+
+BBFILE_COLLECTIONS += "b2qt-toradex"
+BBFILE_PATTERN_b2qt-toradex := "^${LAYERDIR}/"
+BBFILE_PRIORITY_b2qt-toradex = "20"
+
+LAYERDEPENDS_b2qt-toradex = "qt6-layer b2qt"
+
+LAYERSERIES_COMPAT_b2qt-toradex = "kirkstone"
diff --git a/recipes-bsp/tezi-metadata/files/Built_with_Qt.png b/recipes-bsp/tezi-metadata/files/Built_with_Qt.png
new file mode 100644
index 0000000..15f0568
--- /dev/null
+++ b/recipes-bsp/tezi-metadata/files/Built_with_Qt.png
Binary files differ
diff --git a/recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT b/recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT
new file mode 100644
index 0000000..750ad52
--- /dev/null
+++ b/recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT
@@ -0,0 +1,75 @@
+1. QT DEMO IMAGE END USER LICENSE AGREEMENT
+
+This Qt Demo Image End User License Agreement ("Agreement") is a legal agreement between The Qt Company Ltd ("The Qt Company") with its registered office at Bertel Jungin aukio D3A, 02600 Espoo, Finland and You (either an individual or a legal entity) ("Licensee") for the Licensed Software.
+For the purpose of this Agreement Licensed Software shall mean a Qt Demo Image (Boot to Qt software stack) (i) containing demos to highlight the Qt capability on the target hardware for evaluation and demonstration proposes and (ii) supporting deployment of Qt application from Qt Creator.
+Please, read these license terms through carefully. By downloading the Licensed Software, you are deemed to accept these license terms and to commit yourself to observing them. When representing a legal entity, you should ensure your due authorization to approve these terms before such acceptance. Otherwise, we hold you as personally responsible for compliance with this Agreement.
+Under this Agreement, The Qt Company grants the Licensee a license to use Licensed Software solely for the purpose of Licensee's internal testing and evaluation of a Qt Demo Image (Boot to Qt software stack) ("Purpose") for a period of 60 days following the download of the Licensed Software ("Term").
+
+1. OWNERSHIP
+
+The Licensed Software is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The Licensed Software is licensed, not sold.
+All The Qt Company's and/or its licensors' trademarks, service marks, trade names, logos or other words or symbols are and shall remain the exclusive property of The Qt Company or its licensors respectively.
+
+2. LICENSE GRANTED
+
+The Qt Company grants to Licensee a personal, non-exclusive, revocable, non-transferable, free-of-charge license to use the Licensed Software solely for the Purpose during the Term.
+The license granted above in this Section 2 by The Qt Company to Licensee are conditional and subject to Licensee's compliance with the following terms:
+(i) Licensee shall not remove or alter any copyright, trademark or other proprietary rights notice contained in any portion of the Licensed Software;
+(ii) Licensee shall not
+- alter, modify (including creating derivative works), translate or adapt the Licensed Software;
+- reverse engineer, reverse assemble, reverse translate, decompile or reduce to source code form any portion of the Licensed Software; or
+- transfer, publish, disclose, display or otherwise make the Licensed Software available to any third party.
+Any use of Licensed Software beyond the provisions of this Agreement is strictly prohibited and requires an additional license from The Qt Company.
+
+3. WARRANTY DISCLAIMER
+
+LICENSED SOFTWARE IS LICENSED TO LICENSEE "AS IS". TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE QT COMPANY ON BEHALF OF ITSELF AND ITS SUPPLIERS, DISCLAIMS ALL WARRANTIES AND CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT REGARDING TO THE LICENSED SOFTWARE.
+
+4. LIMITATION OF LIABILITY
+
+IN NO EVENT SHALL THE QT COMPANY OR ANY OF ITS AFFILIATES OR THEIR RESPECTIVE LICENSORS BE LIABLE TO LICENSEE FOR ANY INCIDENTAL, CONSEQUENTIAL OR SPECIAL DAMAGES, INCLUDING BUT NOT LIMITED TO ANY LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL DAMAGES, ARISING OUT OF THE USE OR INABILITY TO USE THE LICENSED SOFTWARE, OR ANY BREACH OF ANY OBLIGATION UNDER THIS AGREEMENT. THE FOREGOING LIMITATION OF LIABILITY SHALL REMAIN IN FULL FORCE AND EFFECT REGARDLESS OF WHETHER LICENSEE'S REMEDIES HEREUNDER ARE DETERMINED TO HAVE FAILED OF THEIR ESSENTIAL PURPOSE. THE ENTIRE LIABILITY OF THE QT COMPANY AND THE SOLE AND EXCLUSIVE REMEDY OF LICENSEE, FOR ANY CLAIM OR CAUSE OF ACTION ARISING HEREUNDER (WHETHER IN CONTRACT, TORT, OR OTHERWISE) SHALL NOT EXCEED ONE THOUSAND (1,000) EUROS.
+
+5. CONFIDENTIALITY
+
+Licensee acknowledges and agrees that the Licensed Software contains trade secrets of The Qt Company, its affiliates and/or their respective Licensors and are confidential and proprietary information of the same. Licensee undertakes to keep the Licensed Software strictly confidential and shall not disclose any such information to any third party without the prior written consent of The Qt Company. Licensee shall limit the use and disclosure of the Licensed Software within its organization to the extent necessary for the Purpose, and shall ensure that any of its employees, to whom it gives access hereunder shall comply with the obligations of confidentiality set forth in this Agreement. The Parties acknowledge and agree that monetary damages may not be a sufficient remedy for unauthorized disclosure of The Qt Company's confidential information and that The Qt Company shall be entitled, without waiving any other rights or remedies, to injunctive or equitable relief as may be deemed proper by a court of competent jurisdiction.
+
+6. GENERAL PROVISIONS
+
+6.1 No Assignment
+
+Licensee shall not be entitled to assign or transfer all or any of its rights, benefits and obligations under this Agreement without the prior written consent of The Qt Company, which shall not be unreasonably withheld. The Qt Company shall be entitled to assign or transfer any of its rights, benefits or obligations under this Agreement on an unrestricted basis.
+
+6.2 Term and Termination
+
+This Agreement, and any and all rights of the Licensee thereunder, shall automatically expire three (3) months after the first download of the Licensed Software by the Licensee.
+The Qt Company may terminate the Agreement at any time immediately upon written notice by The Qt Company to Licensee if Licensee breaches this Agreement.
+Either party shall have the right to terminate this Agreement immediately upon written notice in the event that the other party becomes insolvent, files for any form of bankruptcy, makes any assignment for the benefit of creditors, has a receiver, administrative receiver or officer appointed over the whole or a substantial part of its assets, ceases to conduct business, or an act equivalent to any of the above occurs under the laws of the jurisdiction of the other party.
+Upon termination of the Agreement, Licensee shall cease using the Licensed Software. All other copies of Licensed Software in the possession or control of Licensee must be erased or destroyed. An officer of Licensee must, upon request, promptly deliver to The Qt Company a written confirmation that this has occurred.
+
+6.3 Surviving Sections
+
+Any terms and conditions that by their nature or otherwise reasonably should survive a cancellation or termination of this Agreement shall also be deemed to survive. Such surviving terms and conditions include, but are not limited to the Section 5.
+
+6.4 Entire Agreement
+
+This Agreement constitutes the complete agreement between the parties and supersedes all prior or contemporaneous discussions, representations, and proposals, written or oral, with respect to the subject matters discussed herein. No modification of this Agreement shall be effective unless contained in a writing executed by an authorized representative of each party. If any provision of the Agreement is found void or unenforceable, the remainder shall remain valid and enforceable according to its terms.
+
+6.5 Notices
+
+Any notice given by one party to the other shall be deemed properly given and deemed received if specifically acknowledged by the receiving party in writing or when successfully delivered to the recipient by hand, fax, or special courier during normal business hours on a business day to the addresses specified below. Each communication and document made or delivered by one party to the other party pursuant to this Agreement shall be in the English language or accompanied by a translation thereof.
+
+Notices to The Qt Company shall be given to:
+The Qt Company Ltd
+Attn: Legal
+Bertel Jungin Aukio D3A
+FI-02600 Espoo
+Finland
+Fax: +358 10 313 3700
+
+6.6 Governing Law and Legal Venue
+
+This Agreement shall be construed and interpreted in accordance with the laws of Finland, excluding its choice of law provisions. Any disputes, controversy or claim arising out of or relating to this Agreement, or the breach, termination or validity thereof shall be shall be finally settled by arbitration in accordance with the Arbitration Rules of the Finland Chamber of Commerce . The arbitration tribunal shall consist of one (1), or if either Party so requires, of three (3), arbitrators. The award shall be final and binding and enforceable in any court of competent jurisdiction. The arbitration shall be held in Helsinki, Finland and the process shall be conducted in the English language. Notwithstanding the above, the Parties shall also be entitled to seek injunctive or other interim relief in relation to a breach of this Agreement in general courts.
+
+6.7 No Implied License
+
+There are no implied licenses or other implied rights granted under this Agreement, and all rights, save for those expressly granted hereunder, shall remain with The Qt Company and its licensors.
diff --git a/recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend b/recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend
new file mode 100644
index 0000000..b7015f7
--- /dev/null
+++ b/recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI += "\
+ file://TEZI_B2QT_EULA.TXT \
+ file://Built_with_Qt.png \
+ https://qt-files.s3.amazonaws.com/examples/tezi-marketing-20180905.tar;unpack=false;downloadfilename=marketing.tar \
+ "
+
+SRC_URI[md5sum] = "281877560900c6481eee019a923f5e28"
+SRC_URI[sha256sum] = "36c31c812e6d6223f46f2a32cad37f46060a7c05420a4ba491cbea6193039eee"
+
+do_deploy:append () {
+ install -m 644 ${WORKDIR}/TEZI_B2QT_EULA.TXT ${DEPLOYDIR}
+ install -m 644 ${WORKDIR}/Built_with_Qt.png ${DEPLOYDIR}
+}
diff --git a/recipes-core/base-files/base-files_%.bbappend b/recipes-core/base-files/base-files_%.bbappend
new file mode 100644
index 0000000..81d03a4
--- /dev/null
+++ b/recipes-core/base-files/base-files_%.bbappend
@@ -0,0 +1,6 @@
+do_install:append() {
+ # add toradex specific mount point
+ cat >> ${D}${sysconfdir}/fstab <<EOF
+/dev/boot-part /boot auto noatime,noauto 0 0
+EOF
+}
diff --git a/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bbappend b/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bbappend
new file mode 100644
index 0000000..66bdf91
--- /dev/null
+++ b/recipes-core/packagegroups/packagegroup-b2qt-embedded-base.bbappend
@@ -0,0 +1,7 @@
+# try to limit the maximum size of the tezi image
+FIRMWARE ?= ""
+FIRMWARE:colibri-imx6ull = "linux-firmware"
+FIRMWARE:colibri-imx7 = "linux-firmware"
+FIRMWARE:colibri-imx7-emmc = "linux-firmware"
+
+RDEPENDS:${PN}:remove = "${FIRMWARE}"
diff --git a/recipes-kernel/linux/linux-toradex_5.%.bbappend b/recipes-kernel/linux/linux-toradex_5.%.bbappend
new file mode 100644
index 0000000..603a11f
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_5.%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+
+RDEPENDS:${KERNEL_PACKAGE_NAME}-base = "${KERNEL_PACKAGE_NAME}-image ${KERNEL_PACKAGE_NAME}-devicetree"
+
+do_preconfigure:prepend () {
+ # FunctionFS for qdbd
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
+
+ # disable all console messages from framebuffers
+ echo "CONFIG_FRAMEBUFFER_CONSOLE=n" >> ${WORKDIR}/defconfig
+
+ # Enable uprobe for profiling
+ echo "CONFIG_UPROBE_EVENT=y" >> ${WORKDIR}/defconfig
+ echo "CONFIG_FTRACE=y" >> ${WORKDIR}/defconfig
+}
diff --git a/recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch b/recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch
new file mode 100644
index 0000000..2c0530e
--- /dev/null
+++ b/recipes-multimedia/alsa-utils/alsa-utils/0001-Increase-default-playback-volume.patch
@@ -0,0 +1,26 @@
+From 804c0ca68e18a3e83ccbf49d0476fce3eb739477 Mon Sep 17 00:00:00 2001
+From: Kari Oikarinen <kari.oikarinen@qt.io>
+Date: Mon, 11 Dec 2017 13:55:27 +0200
+Subject: [PATCH] Increase default playback volume
+
+It is too quiet otherwise on Apalis iMX6.
+---
+ alsactl/init/default | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/alsactl/init/default b/alsactl/init/default
+index 1c84f3e..af41576 100644
+--- a/alsactl/init/default
++++ b/alsactl/init/default
+@@ -12,7 +12,7 @@
+
+ ENV{ppercent}:="75%"
+ ENV{cpercent}:="75%"
+-ENV{pvolume}:="-20dB"
++ENV{pvolume}:="5dB"
+ ENV{cvolume}:="12dB"
+ ENV{has_pmaster_vol}:="false"
+
+--
+2.11.0
+
diff --git a/recipes-multimedia/alsa-utils/alsa-utils_%.bbappend b/recipes-multimedia/alsa-utils/alsa-utils_%.bbappend
new file mode 100644
index 0000000..32b7d66
--- /dev/null
+++ b/recipes-multimedia/alsa-utils/alsa-utils_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append:apalis-imx6 = " file://0001-Increase-default-playback-volume.patch"
diff --git a/recipes-qt/boot2qt-addons/qbsp-readme.bbappend b/recipes-qt/boot2qt-addons/qbsp-readme.bbappend
new file mode 100644
index 0000000..4fc41d0
--- /dev/null
+++ b/recipes-qt/boot2qt-addons/qbsp-readme.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/recipes-qt/boot2qt-addons/qbsp-readme/README b/recipes-qt/boot2qt-addons/qbsp-readme/README
new file mode 100644
index 0000000..1903570
--- /dev/null
+++ b/recipes-qt/boot2qt-addons/qbsp-readme/README
@@ -0,0 +1,66 @@
+To successfully set up the Boot to Qt software stack,
+follow the instructions in https://doc.qt.io/Boot2Qt/b2qt-qbsp-installation-guide.html#.
+
+In 2. Installing Boot to Qt on Target Device, see also the following device specific instructions:
+
+
+2. Installing Boot to Qt on Target Device
+
+To flash the image, you can use either Toradex Easy Installer
+(https://developer.toradex.com/software/toradex-easy-installer#) or Qt's Flashing Wizard.
+With Toradex Easy Installer, the image is flashed to the device's internal eMMC
+flash memory.
+
+
+2.1 Flashing with Toradex Easy Installer:
+
+When Toradex Easy Installer is connected to the Internet, it automatically provides
+the latest Boot to Qt image in its image list but that is not necessarily compatible
+with your Boot to Qt installation. When you flash with Toradex Easy Installer,
+you should always use the *.tezi.tar package that is included into the Boot to Qt
+installation.
+
+Flash the Boot to Qt image with Toradex Easy Installer as follows:
+
+1. If your target device does not have the pre-installed Toradex Easy Installer,
+follow instructions in https://developer.toradex.com/software/toradex-easy-installer#load-toradex-easy-installer#
+to load Toradex Easy Installer.
+2. Your Boot to Qt installation has the *.tezi.tar package under
+<Qt installation directory>/<Qt version>/Boot2Qt/<target>/images. Extract the package
+to an SD card or a USB flash drive.
+3. Flash the image from the SD card or the USB flash drive with Toradex Easy Installer.
+See https://developer.toradex.com/software/toradex-easy-installer#installing-the-images.
+
+
+2.2 Flashing with Qt's Flashing Wizard
+
+Use Flashing Wizard to flash the image to your device:
+
+1. Connect your SD card reader to the development host. Make sure that the SD card size is at least 4 GB.
+2. Launch Qt Creator.
+3. Select Tools > Flash Boot to Qt Device, and follow the instructions in Flashing Wizard.
+
+In order to boot from the external SD card, U-Boot needs to be updated.
+
+
+2.3 Booting from External SD Card
+
+Connect a serial cable to the device and enter into the U-Boot environment by
+pressing any key before the autoboot.
+
+Enter following commands into U-Boot:
+
+run setupdate
+run update
+
+Reset or power cycle the device to start the new U-Boot.
+To reset the U-Boot environment to new default values, enter the following commands in the U-Boot command line:
+
+env default -a
+saveenv
+
+New U-Boot commands are now stored into the device.
+
+For more information about the boot process on the Toradex Colibri devices,
+see https://developer.toradex.com/knowledge-base/linux-booting.
+
diff --git a/recipes-qt/boot2qt-addons/qbsp-readme/mx8-generic-bsp/README b/recipes-qt/boot2qt-addons/qbsp-readme/mx8-generic-bsp/README
new file mode 100644
index 0000000..3b876f1
--- /dev/null
+++ b/recipes-qt/boot2qt-addons/qbsp-readme/mx8-generic-bsp/README
@@ -0,0 +1,52 @@
+To successfully set up the Boot to Qt software stack,
+follow the instructions in https://doc.qt.io/Boot2Qt/b2qt-qbsp-installation-guide.html#.
+
+In 2. Installing Boot to Qt on Target Device, see also the following device specific instructions.
+
+
+2. Installing Boot to Qt on Target Device
+
+To flash the image, you can use either Toradex Easy Installer
+(https://developer.toradex.com/software/toradex-easy-installer#) or Qt's Flashing Wizard.
+
+
+2.1 Flashing with Toradex Easy Installer:
+
+When Toradex Easy Installer is connected to the Internet, it automatically provides
+the latest Boot to Qt image in its image list but that is not necessarily compatible
+with your Boot to Qt installation. When you flash with Toradex Easy Installer,
+you should always use the *.tezi.tar package that is included into the Boot to Qt
+installation.
+
+Flash the Boot to Qt image with Toradex Easy Installer as follows:
+
+1. If your target device does not have the pre-installed Toradex Easy Installer,
+follow instructions in https://developer.toradex.com/software/toradex-easy-installer#load-toradex-easy-installer#
+to load Toradex Easy Installer.
+2. Your Boot to Qt installation has the *.tezi.tar package under
+<Qt installation directory>/<Qt version>/Boot2Qt/<target>/images. Extract the package
+to an SD card or a USB flash drive.
+3. Flash the image from the SD card or the USB flash drive with Toradex Easy Installer.
+See https://developer.toradex.com/software/toradex-easy-installer#installing-the-images.
+
+
+2.2 Flashing with Qt's Flashing Wizard
+
+1. Use the RS-232 cable to access the serial terminal on Toradex board.
+2. Power on your device and press any key to stop the autoboot.
+3. Run the following command in U-Boot:
+
+ums 0 mmc 0
+
+4. Connect your device to the development host using USB On-The-Go (OTG).
+5. Use Flashing Wizard to flash the image to the device:
+ 5.1 Launch Qt Creator.
+ 5.2 Select Tools > Flash Boot to Qt Device, and follow the instructions in Flashing Wizard.
+6. Press Ctrl+C in the U-Boot console and run the reset command.
+
+Note: The u-boot is not updated when using the Flashing Wizard.
+
+For more information about flashing the Toradex devices,
+see https://developer.toradex.com/software/linux/linux-software/build-apalis-imx8-yoctoopenembedded-bring-up-image#emmc-boot#.
+
+Note: The Boot to Qt software stack supports only the v1.0B silicon.