aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-05-16 10:56:46 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-05-25 13:34:11 +0000
commitc157da242f4d79ca4bb006f448c645ef59da80a7 (patch)
tree5553df0a3c88e6e83b80166eaddd3bf73fb164db
parent1feed6eb2e41e613f59cc5bfa569cacaf1fe2752 (diff)
qtspeech: add support for flite speech synthesis engine
Add recipe for flite and use it as a backend for QtSpeech. Task-number: QTBUG-102978 Change-Id: Iefd9d3819e9e9e94f46abee19145d0685b23e1ee Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt6/qtspeech_git.bbappend30
-rw-r--r--meta-boot2qt/recipes-multimedia/flite/flite_2.2.bb18
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt6/qtspeech_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt6/qtspeech_git.bbappend
new file mode 100644
index 00000000..1a4782c6
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt6/qtspeech_git.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2022 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PACKAGECONFIG += "flite"
diff --git a/meta-boot2qt/recipes-multimedia/flite/flite_2.2.bb b/meta-boot2qt/recipes-multimedia/flite/flite_2.2.bb
new file mode 100644
index 00000000..de2ccc26
--- /dev/null
+++ b/meta-boot2qt/recipes-multimedia/flite/flite_2.2.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Flite: a small run-time speech synthesis engine"
+SECTION = "libs/multimedia"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
+
+inherit autotools-brokensep
+
+SRC_URI = "git://github.com/festvox/flite.git;protocol=https;branch=master"
+
+SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF += "--enable-shared"
+
+do_install:append() {
+ chown -R root:root ${D}${libdir}/*
+}