aboutsummaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-26 10:56:59 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-28 08:58:06 +0000
commit4fba985f5877320a2354f85646ec145804fe8c28 (patch)
tree60bcf765888b09ee8e33502171edc10d3469a1bd /meta-tegra-extras
parent5e33d73dcdaa1b622460bb082cb011dc9e589d09 (diff)
jetson: update to sumo
Update meta-tegra layer to the latest revision on sumo branch and make the necessary adaptations. Change-Id: I4119fdf43507645ae3c02da01e3695cdbedf6321 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/recipes/drm/libdrm_%.bbappend15
-rw-r--r--meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend4
-rw-r--r--meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend37
3 files changed, 1 insertions, 55 deletions
diff --git a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
deleted file mode 100644
index bf4cc080..00000000
--- a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-inherit update-alternatives
-
-do_install_append() {
- mv ${D}${libdir}/libdrm.so.2.4.0 ${D}${libdir}/libdrm-freedesktop.so.2.4.0
- rm ${D}${libdir}/libdrm.so
- rm ${D}${libdir}/libdrm.so.2
- ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so
- ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so.2
-}
-
-ALTERNATIVE_${PN} = "libdrm.so.2.4.0 libdrm.so.2"
-ALTERNATIVE_LINK_NAME[libdrm.so.2.4.0] = "${libdir}/libdrm.so.2.4.0"
-ALTERNATIVE_LINK_NAME[libdrm.so.2] = "${libdir}/libdrm.so.2"
-ALTERNATIVE_TARGET = "${libdir}/libdrm-freedesktop.so.2.4.0"
-ALTERNATIVE_PRIORITY = "20"
diff --git a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
index d3c48035..14506228 100644
--- a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
+++ b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2017 The Qt Company Ltd.
+## Copyright (C) 2018 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -31,5 +31,3 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "\
file://0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch \
"
-
-require recipes-kernel/linux/linux-dtb.inc
diff --git a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
deleted file mode 100644
index 84a817ce..00000000
--- a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
+++ /dev/null
@@ -1,37 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2017 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-PACKAGES += "${PN}-dev"
-RRECOMMENDS_${PN}-dev += "\
- libgles1-mesa-dev \
- libgles2-mesa-dev \
- libgles3-mesa-dev \
- libegl-mesa-dev \
- libgl-mesa-dev \
- "