aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2024-04-20 17:31:23 +0200
committerMartin Jansa <martin.jansa@gmail.com>2024-04-22 12:18:18 +0200
commitbb651046c012a991ae0bdcc71735eb3ce58537f6 (patch)
treec4ab9971cf45df8c1f8165c6d941cbd7c924452a
parentc0f3c1f99d512e2f95aaaed7022b66d3acff9102 (diff)
layer: Reinstate support for older OE releases
Reinstate support for older OE releases by using inherit_defer only for OE Scarthgap release, while retaining the old behavior for all the recently supported older OE releases. Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--compat/legacy/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend1
-rw-r--r--compat/scarthgap/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend1
-rw-r--r--conf/layer.conf3
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb1
4 files changed, 5 insertions, 1 deletions
diff --git a/compat/legacy/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend b/compat/legacy/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend
new file mode 100644
index 00000000..228194f4
--- /dev/null
+++ b/compat/legacy/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend
@@ -0,0 +1 @@
+inherit nativesdk
diff --git a/compat/scarthgap/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend b/compat/scarthgap/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend
new file mode 100644
index 00000000..7efe1aee
--- /dev/null
+++ b/compat/scarthgap/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bbappend
@@ -0,0 +1 @@
+inherit_defer nativesdk
diff --git a/conf/layer.conf b/conf/layer.conf
index 59fd2ff2..08a01dc0 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -39,3 +39,6 @@ QT_GIT_PROJECT ?= "qt"
QT_GIT ?= "git://code.qt.io/${QT_GIT_PROJECT}"
QT_GIT_PROTOCOL ?= "git"
QT_EDITION ?= "opensource"
+
+# Compatibility handling to support pre-Scarthgap OE releases.
+BBFILES += "${LAYERDIR}/compat/${@'scarthgap' if 'scarthgap' in d.getVar('LAYERSERIES_CORENAMES').split() else 'legacy'}/*/*/*.bbappend"
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
index 5ad0cedd..531bb14b 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
@@ -4,7 +4,6 @@ SUMMARY = "Host packages for the Qt5 standalone SDK or external toolchain"
LICENSE = "MIT"
inherit packagegroup
-inherit_defer nativesdk
PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"