aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorJani Suonpera <jani.suonpera@qt.io>2021-09-22 13:44:05 +0300
committerJani Suonpera <jani.suonpera@qt.io>2021-09-23 06:30:11 +0000
commit9155b94538e1834f3b2027f13699727772d3ecbc (patch)
tree6fbece63baeb3154ad0c04ace28c98bc196fab0b /recipes-qt/qt5
parent1a30142e7cfd82962fbacfc6b65f5c1fc046aa5d (diff)
parent10f3673fd4b6c6e1e61c23478802f83652475a5f (diff)
Merge commit '10f3673f' into lts-5.15
10f3673f is last SHA1 in upstream master, which does not include Yocto branch Honister. Task-number: QTBUG-96310 Change-Id: I6c9cb67693d8594d727d91e559b190db633a0f67
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch49
-rw-r--r--recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch32
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb6
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
5 files changed, 87 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch b/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch
new file mode 100644
index 00000000..e03ef5b7
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch
@@ -0,0 +1,49 @@
+From 14eb5b382cabf90352634393c19bf87a4c15766a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Mon, 8 Mar 2021 21:56:06 +0100
+Subject: [PATCH] clangformat: Fix build with LLVM 13
+
+Change-Id: I5eaad17a6f240aa1e3f246492b69f093b4f59fee
+Reviewed-by: David Schulz <david.schulz@qt.io>
+
+Upstream-Status: Accepted [https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=14eb5b382cabf90352634393c19bf87a4c15766a]
+---
+ src/plugins/clangformat/clangformatbaseindenter.cpp | 4 ++++
+ src/plugins/clangformat/clangformatutils.cpp | 4 ++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatbaseindenter.cpp b/src/plugins/clangformat/clangformatbaseindenter.cpp
+index fb8e693809..6378b2af53 100644
+--- a/src/plugins/clangformat/clangformatbaseindenter.cpp
++++ b/src/plugins/clangformat/clangformatbaseindenter.cpp
+@@ -42,7 +42,11 @@ void adjustFormatStyleForLineBreak(clang::format::FormatStyle &style,
+ ReplacementsToKeep replacementsToKeep)
+ {
+ style.MaxEmptyLinesToKeep = 100;
++#if LLVM_VERSION_MAJOR >= 13
++ style.SortIncludes = clang::format::FormatStyle::SI_Never;
++#else
+ style.SortIncludes = false;
++#endif
+ style.SortUsingDeclarations = false;
+
+ // This is a separate pass, don't do it unless it's the full formatting.
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index a249327d0e..770e75908c 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -145,7 +145,11 @@ static clang::format::FormatStyle qtcStyle()
+ style.PenaltyReturnTypeOnItsOwnLine = 300;
+ style.PointerAlignment = FormatStyle::PAS_Right;
+ style.ReflowComments = false;
++#ifdef LLVM_VERSION_MAJOR >= 13
++ style.SortIncludes = FormatStyle::SI_CaseSensitive;
++#else
+ style.SortIncludes = true;
++#endif
+ style.SortUsingDeclarations = true;
+ style.SpaceAfterCStyleCast = true;
+ style.SpaceAfterTemplateKeyword = false;
+--
+2.31.1
+
diff --git a/recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch b/recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch
new file mode 100644
index 00000000..33761797
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch
@@ -0,0 +1,32 @@
+From 55b91a76172a3235b4879daf0b675519d5b02db7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Wed, 16 Jun 2021 20:59:29 +0200
+Subject: [PATCH] clangformat: Fix build with LLVM 13
+
+Change-Id: Ia9db10696fd129c8b989ecc4c9ecbb7f1f10e68c
+Reviewed-by: David Schulz <david.schulz@qt.io>
+
+Upstream-Status: Accepted [https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=55b91a76172a3235b4879daf0b675519d5b02db7]
+---
+ src/plugins/clangformat/clangformatutils.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index 2f9a306b99..3905ae5f6a 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -157,7 +157,11 @@ static clang::format::FormatStyle qtcStyle()
+ style.SpaceBeforeParens = FormatStyle::SBPO_ControlStatements;
+ style.SpaceInEmptyParentheses = false;
+ style.SpacesBeforeTrailingComments = 1;
++#if LLVM_VERSION_MAJOR >= 13
++ style.SpacesInAngles = FormatStyle::SIAS_Never;
++#else
+ style.SpacesInAngles = false;
++#endif
+ style.SpacesInContainerLiterals = false;
+ style.SpacesInCStyleCastParentheses = false;
+ style.SpacesInParentheses = false;
+--
+2.31.1
+
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index d89b0758..1d0e2216 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -17,14 +17,16 @@ inherit qmake5 mime-xdg
DEPENDS += "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib"
DEPENDS_append_libc-musl = " libexecinfo"
-SRCREV = "978f6caf1e18ad0b0415fde60a8c130448969c6d"
-PV = "4.15.0+git${SRCPV}"
+SRCREV = "94d227cd434d09717de95529e5210ec530451e1c"
+PV = "4.15.2+git${SRCPV}"
# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.9.2
# 4.9.2.meta-qt5.1
SRC_URI = " \
git://code.qt.io/qt-creator/qt-creator.git;branch=4.15 \
file://0001-app-Use-malloc_trim-only-on-glibc.patch \
file://0001-Fix-interface-of-propertyNameListForWritableProperti.patch \
+ file://0002-clangformat-Fix-build-with-LLVM-13.patch \
+ file://0003-clangformat-Fix-build-with-LLVM-13.patch \
"
SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 4982dfd1..d5559279 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -20,7 +20,7 @@ SRC_URI += "file://0001-tst_seatv4-Include-array.patch"
PACKAGECONFIG ?= " \
wayland-client \
wayland-server \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'wayland-egl', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl wayland', 'wayland-egl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcomposite-egl xcomposite-glx', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'wayland-vulkan-server-buffer', '', d)} \
"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 5f4bb9d2..1a74af97 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = " \
"
DEPENDS += " \
+ dbus \
libpng-native \
nss-native \
nspr-native \