aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/qmake5_base.bbclass7
-rw-r--r--recipes-connectivity/libconnman-qt/libconnman-qt5/0001-Don-t-use-MeeGo-as-prefix-in-order-to-make-this-a-co.patch25
-rw-r--r--recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb4
-rw-r--r--recipes-connectivity/libqofono/libqofono_git.bb4
-rw-r--r--recipes-qt/examples/qt5everywheredemo_1.0.bb8
-rw-r--r--recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb4
-rw-r--r--recipes-qt/qt5/qt5-ptest.inc5
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb13
-rw-r--r--recipes-qt/qt5/qtbase/0010-Add-OE-specific-specs-for-clang-compiler.patch72
-rw-r--r--recipes-qt/qt5/qtbase/0011-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch35
-rw-r--r--recipes-qt/qt5/qtbase/0012-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch28
-rw-r--r--recipes-qt/qt5/qtbase_git.bb8
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb4
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb1
-rw-r--r--recipes-qt/qt5/qtenginio_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb1
-rw-r--r--recipes-qt/qt5/qtscript_git.bb1
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb1
-rw-r--r--recipes-qt/qt5/qtsystems_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb1
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb1
-rw-r--r--recipes-qt/qtchooser/qtchooser_git.bb6
-rw-r--r--recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch29
-rw-r--r--recipes-qt/tufao/tufao_1.3.10.bb (renamed from recipes-qt/tufao/tufao_1.2.1.bb)4
24 files changed, 211 insertions, 55 deletions
diff --git a/classes/qmake5_base.bbclass b/classes/qmake5_base.bbclass
index 538c9489..3bc1279d 100644
--- a/classes/qmake5_base.bbclass
+++ b/classes/qmake5_base.bbclass
@@ -1,6 +1,9 @@
# hardcode linux, because that's what 0001-Add-linux-oe-g-platform.patch adds
-OE_QMAKE_PLATFORM_NATIVE = "linux-oe-g++"
-OE_QMAKE_PLATFORM = "linux-oe-g++"
+XPLATFORM_toolchain-clang = "linux-oe-clang"
+XPLATFORM ?= "linux-oe-g++"
+
+OE_QMAKE_PLATFORM_NATIVE = "${XPLATFORM}"
+OE_QMAKE_PLATFORM = "${XPLATFORM}"
# Add -d to show debug output from every qmake call, but it prints *a lot*, better to add it only to debugged recipe
OE_QMAKE_DEBUG_OUTPUT ?= ""
diff --git a/recipes-connectivity/libconnman-qt/libconnman-qt5/0001-Don-t-use-MeeGo-as-prefix-in-order-to-make-this-a-co.patch b/recipes-connectivity/libconnman-qt/libconnman-qt5/0001-Don-t-use-MeeGo-as-prefix-in-order-to-make-this-a-co.patch
index 75943db0..7a67c744 100644
--- a/recipes-connectivity/libconnman-qt/libconnman-qt5/0001-Don-t-use-MeeGo-as-prefix-in-order-to-make-this-a-co.patch
+++ b/recipes-connectivity/libconnman-qt/libconnman-qt5/0001-Don-t-use-MeeGo-as-prefix-in-order-to-make-this-a-co.patch
@@ -1,22 +1,23 @@
-From 46b6456bc8995b8d6249fb008a538222d30716cd Mon Sep 17 00:00:00 2001
+From 827b323ee9a6db04c1f5b644abea0ced2095096a Mon Sep 17 00:00:00 2001
From: Christophe Chapuis <chris.chapuis@gmail.com>
Date: Tue, 26 Jan 2016 18:56:42 +0100
Subject: [PATCH] Don't use MeeGo as prefix in order to make this a common
component
Signed-off-by: Christophe Chapuis <chris.chapuis@gmail.com>
+Signed-off-by: Herman van Hazendonk <github.com@herrie.org>
---
- plugin/components.h | 2 +-
- plugin/plugin.pro | 2 +-
- plugin/qmldir | 2 +-
+ plugin/plugin.cpp | 2 +-
+ plugin/plugin.pro | 2 +-
+ plugin/qmldir | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
-diff --git a/plugin/components.h b/plugin/components.h
-index d4f2bcd..49b7ac2 100644
---- a/plugin/components.h
-+++ b/plugin/components.h
-@@ -17,7 +17,7 @@
- class Components : public QQmlExtensionPlugin
+diff --git a/plugin/plugin.cpp b/plugin/plugin.cpp
+index a383482..451c95f 100644
+--- a/plugin/plugin.cpp
++++ b/plugin/plugin.cpp
+@@ -24,7 +24,7 @@
+ class ConnmanPlugin: public QQmlExtensionPlugin
{
Q_OBJECT
- Q_PLUGIN_METADATA(IID "MeeGo.Connman")
@@ -25,7 +26,7 @@ index d4f2bcd..49b7ac2 100644
public:
void registerTypes(const char *uri);
diff --git a/plugin/plugin.pro b/plugin/plugin.pro
-index 31d9076..da47ad9 100644
+index c4f54cf..3763f57 100644
--- a/plugin/plugin.pro
+++ b/plugin/plugin.pro
@@ -17,7 +17,7 @@ LIBS += -l$$qtLibraryTarget(connman-$$TARGET_SUFFIX)
@@ -46,5 +47,5 @@ index 5db82b7..de56688 100644
+module Connman
plugin ConnmanQtDeclarative
--
-1.8.1.2
+2.11.0.windows.3
diff --git a/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb b/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb
index 9605777d..ecd295c3 100644
--- a/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb
+++ b/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb
@@ -5,9 +5,9 @@ HOMEPAGE = "https://git.merproject.org/mer-core/libconnman-qt"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88"
DEPENDS += "qtbase qtdeclarative"
-PV = "1.1.10+git${SRCPV}"
+PV = "1.2.4+git${SRCPV}"
-SRCREV = "4d6def3053eaccaac04e4f9e03ee24dea8b9e8d8"
+SRCREV = "9d98e12ed60ae4fa9da62485cb8a82129ed1a464"
SRC_URI = "git://git.merproject.org/mer-core/libconnman-qt.git;protocol=https \
file://0001-Don-t-use-MeeGo-as-prefix-in-order-to-make-this-a-co.patch \
"
diff --git a/recipes-connectivity/libqofono/libqofono_git.bb b/recipes-connectivity/libqofono/libqofono_git.bb
index 88df1351..18e9b8fd 100644
--- a/recipes-connectivity/libqofono/libqofono_git.bb
+++ b/recipes-connectivity/libqofono/libqofono_git.bb
@@ -5,11 +5,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "54435de3bed0b454ef4ea3ea32c7234fcd9f24c6"
+SRCREV = "6916cd030b05f0bd137ea9b669fee48f20c19084"
SRC_URI = "git://git.merproject.org/mer-core/libqofono.git"
S = "${WORKDIR}/git"
-PV = "0.87+gitr${SRCPV}"
+PV = "0.92+gitr${SRCPV}"
inherit qmake5
diff --git a/recipes-qt/examples/qt5everywheredemo_1.0.bb b/recipes-qt/examples/qt5everywheredemo_1.0.bb
index 7735d902..ee947991 100644
--- a/recipes-qt/examples/qt5everywheredemo_1.0.bb
+++ b/recipes-qt/examples/qt5everywheredemo_1.0.bb
@@ -1,12 +1,12 @@
SUMMARY = "Qt5 everywhere demo"
DESCRIPTION = "Quick tour of Qt 5.0, primarily focusing on its graphical capabilities."
+LICENSE = "BSD"
HOMEPAGE = "https://qt.gitorious.org/qt-labs"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://main.cpp;md5=1187cb795a0f96bce64e63dd1a67dc2b"
+LIC_FILES_CHKSUM = "file://qml/QtDemo/main.qml;endline=39;md5=7d80863906a4bc8ffca77fd869e335a9"
-DEPENDS = "qtdeclarative qtgraphicaleffects"
+DEPENDS = "qtdeclarative qtgraphicaleffects qtsvg qtmultimedia"
-SRCREV = "c17fe9e0ec0882ac4c4dc1168095f569acab5d09"
+SRCREV = "35d72a2eba7456a2efc5eb8b77afbc00f69ba0ac"
SRC_URI = "${QT_LABS_GIT}/qt-labs-qt5-everywhere-demo"
S = "${WORKDIR}/git/QtDemo"
diff --git a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
index 2676bdd7..383145be 100644
--- a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
+++ b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = " \
file://evdevmousehandler.cpp;beginline=1;endline=40;md5=9081062f6e7f74b6e62ad7ecee4a71be \
"
-PV = "1.1.3+gitr${SRCPV}"
+PV = "1.1.4+gitr${SRCPV}"
DEPENDS = "qtbase"
@@ -17,7 +17,7 @@ DEPENDS = "qtbase"
CXXFLAGS += "-Wno-narrowing"
SRC_URI = "git://github.com/nemomobile/qt5-plugin-generic-vboxtouch.git"
-SRCREV = "d613ad1cc64d7a6a9b38df4d49146170be6876aa"
+SRCREV = "3f2bdb5a1d346f02d5ab185522271ba2288a42bb"
S = "${WORKDIR}/git/vboxtouch"
inherit qmake5
diff --git a/recipes-qt/qt5/qt5-ptest.inc b/recipes-qt/qt5/qt5-ptest.inc
index 4844878a..97bce88e 100644
--- a/recipes-qt/qt5/qt5-ptest.inc
+++ b/recipes-qt/qt5/qt5-ptest.inc
@@ -4,8 +4,9 @@ inherit ptest
addtask do_populate_sysroot after do_install before do_compile_ptest_base
deltask do_compile_ptest_base
-addtask do_compile_ptest_base after do_populate_sysroot before do_install_ptest
-addtask do_install_ptest after do_compile_ptest_base before do_package
+addtask do_compile_ptest_base after do_populate_sysroot before do_install_ptest_base
+deltask do_install_ptest_base
+addtask do_install_ptest_base after do_compile_ptest_base before do_package
do_compile_ptest() {
cd ${S}/tests
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 5a37a9e4..b0f59701 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -38,14 +38,21 @@ SRC_URI += "\
# 5.9.meta-qt5-native.2
SRC_URI += " \
file://0009-Always-build-uic.patch \
+ file://0010-Add-OE-specific-specs-for-clang-compiler.patch \
+ file://0011-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
+ file://0012-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
"
CLEANBROKEN = "1"
+XPLATFORM_toolchain-clang = "linux-oe-clang"
+XPLATFORM ?= "linux-oe-g++"
+
PACKAGECONFIG_CONFARGS = " \
-sysroot ${STAGING_DIR_NATIVE} \
-no-gcc-sysroot \
-system-zlib \
+ -qt-pcre \
-no-libjpeg \
-no-libpng \
-no-gif \
@@ -79,7 +86,7 @@ PACKAGECONFIG_CONFARGS = " \
-nomake examples \
-nomake tests \
-no-rpath \
- -platform linux-oe-g++ \
+ -platform ${XPLATFORM} \
"
# for qtbase configuration we need default settings
@@ -112,6 +119,10 @@ do_install() {
fi
install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
+
+ # since 5.9.2 something sets a very strange path to mkspec ("${_qt5Core_install_prefix}/../../../../../../../../../../usr/lib/qt5//mkspecs/linux-oe-g++")
+ # override this until somebody finds a better way
+ echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
SRCREV = "ec16ba393baf504d4b192cc349775c62d3c96aa0"
diff --git a/recipes-qt/qt5/qtbase/0010-Add-OE-specific-specs-for-clang-compiler.patch b/recipes-qt/qt5/qtbase/0010-Add-OE-specific-specs-for-clang-compiler.patch
new file mode 100644
index 00000000..b019f67c
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0010-Add-OE-specific-specs-for-clang-compiler.patch
@@ -0,0 +1,72 @@
+From 3a46fb7b47d19c5261e1590f8d70fe41443def64 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 3 Sep 2017 09:11:44 -0700
+Subject: [PATCH] Add OE specific specs for clang compiler
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mkspecs/linux-oe-clang/qmake.conf | 43 ++++++++++++++++++++++++++++++++++
+ mkspecs/linux-oe-clang/qplatformdefs.h | 1 +
+ 2 files changed, 44 insertions(+)
+ create mode 100644 mkspecs/linux-oe-clang/qmake.conf
+ create mode 100644 mkspecs/linux-oe-clang/qplatformdefs.h
+
+diff --git a/mkspecs/linux-oe-clang/qmake.conf b/mkspecs/linux-oe-clang/qmake.conf
+new file mode 100644
+index 0000000000..ffc9f051db
+--- /dev/null
++++ b/mkspecs/linux-oe-clang/qmake.conf
+@@ -0,0 +1,43 @@
++#
++# qmake configuration for linux-g++ with modifications for building with OpenEmbedded
++#
++
++MAKEFILE_GENERATOR = UNIX
++CONFIG += incremental
++QMAKE_INCREMENTAL_STYLE = sublib
++
++include(../common/linux.conf)
++
++# QMAKE_<TOOL> (moc, uic, rcc) are gone, overwrite only ar and strip
++QMAKE_AR = $$(OE_QMAKE_AR) cqs
++QMAKE_STRIP = $$(OE_QMAKE_STRIP)
++QMAKE_WAYLAND_SCANNER = $$(OE_QMAKE_WAYLAND_SCANNER)
++
++include(../common/gcc-base-unix.conf)
++
++# *FLAGS from gcc-base.conf
++QMAKE_CFLAGS += $$(OE_QMAKE_CFLAGS)
++QMAKE_CXXFLAGS += $$(OE_QMAKE_CXXFLAGS)
++QMAKE_LFLAGS += $$(OE_QMAKE_LDFLAGS)
++
++include(../common/clang.conf)
++
++# tc settings from g++-base.conf
++QMAKE_COMPILER = $$(OE_QMAKE_COMPILER) clang
++QMAKE_CC = $$(OE_QMAKE_CC)
++QMAKE_CXX = $$(OE_QMAKE_CXX)
++
++QMAKE_CFLAGS_RELEASE_WITH_DEBUGINFO += $$(OE_QMAKE_CFLAGS)
++
++QMAKE_LINK = $$(OE_QMAKE_LINK)
++QMAKE_LINK_SHLIB = $$(OE_QMAKE_LINK)
++QMAKE_LINK_C = $$(OE_QMAKE_LINK)
++QMAKE_LINK_C_SHLIB = $$(OE_QMAKE_LINK)
++
++# for the SDK
++isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $$(OE_QMAKE_QT_CONFIG)
++
++include(../oe-device-extra.pri)
++
++load(device_config)
++load(qt_config)
+diff --git a/mkspecs/linux-oe-clang/qplatformdefs.h b/mkspecs/linux-oe-clang/qplatformdefs.h
+new file mode 100644
+index 0000000000..880c927b21
+--- /dev/null
++++ b/mkspecs/linux-oe-clang/qplatformdefs.h
+@@ -0,0 +1 @@
++#include "../linux-clang/qplatformdefs.h"
+--
+2.14.1
+
diff --git a/recipes-qt/qt5/qtbase/0011-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch b/recipes-qt/qt5/qtbase/0011-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
new file mode 100644
index 00000000..0c7fb874
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0011-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
@@ -0,0 +1,35 @@
+From 8394ad48f454aa292e4da57b3b75a3701dadcf96 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 3 Sep 2017 09:44:48 -0700
+Subject: [PATCH] linux-clang: Invert conditional for defining QT_SOCKLEN_T
+
+This helps to make sure that QT_SOCKLEN_T is defined to be 'int'
+only when its glibc < 2 and not for other libcswhich may define
+it as per standards but are not glibc, e.g. musl
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mkspecs/linux-clang/qplatformdefs.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mkspecs/linux-clang/qplatformdefs.h b/mkspecs/linux-clang/qplatformdefs.h
+index d29225f12f..a0cdb57343 100644
+--- a/mkspecs/linux-clang/qplatformdefs.h
++++ b/mkspecs/linux-clang/qplatformdefs.h
+@@ -84,10 +84,10 @@
+
+ #undef QT_SOCKLEN_T
+
+-#if defined(__GLIBC__) && (__GLIBC__ >= 2)
+-#define QT_SOCKLEN_T socklen_t
+-#else
++#if defined(__GLIBC__) && (__GLIBC__ < 2)
+ #define QT_SOCKLEN_T int
++#else
++#define QT_SOCKLEN_T socklen_t
+ #endif
+
+ #if defined(_XOPEN_SOURCE) && (_XOPEN_SOURCE >= 500)
+--
+2.14.1
+
diff --git a/recipes-qt/qt5/qtbase/0012-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch b/recipes-qt/qt5/qtbase/0012-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
new file mode 100644
index 00000000..a1776258
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0012-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
@@ -0,0 +1,28 @@
+From 30076434a9f651614db8c3e5db32d4acae54c600 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 3 Sep 2017 10:11:50 -0700
+Subject: [PATCH] tst_qlocale: Enable QT_USE_FENV only on glibc
+
+musl does not have feenableexcept function
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tests/auto/corelib/tools/qlocale/tst_qlocale.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp b/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp
+index 10d78b1f2f..a59f358f80 100644
+--- a/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp
++++ b/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp
+@@ -46,7 +46,7 @@
+ #include <private/qlocale_tools_p.h>
+ #include <qnumeric.h>
+
+-#if defined(Q_OS_LINUX) && !defined(__UCLIBC__)
++#if defined(Q_OS_LINUX) && defined(__GLIBC__)
+ # define QT_USE_FENV
+ #endif
+
+--
+2.14.1
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 3ae2dfc1..802da3b4 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -26,6 +26,9 @@ SRC_URI += "\
file://0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
file://0007-Delete-qlonglong-and-qulonglong.patch \
file://0008-Replace-pthread_yield-with-sched_yield.patch \
+ file://0010-Add-OE-specific-specs-for-clang-compiler.patch \
+ file://0011-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch \
+ file://0012-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch \
file://run-ptest \
"
@@ -160,6 +163,9 @@ QT_CONFIG_FLAGS += " \
# since we cannot set empty set filename to a not existent file
deltask generate_qt_config_file
+XPLATFORM_toolchain-clang = "linux-oe-clang"
+XPLATFORM ?= "linux-oe-g++"
+
do_configure() {
# Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory" during configuration
touch ${S}/mkspecs/oe-device-extra.pri
@@ -188,7 +194,7 @@ do_configure() {
-external-hostbindir ${OE_QMAKE_PATH_EXTERNAL_HOST_BINS} \
-hostdatadir ${OE_QMAKE_PATH_HOST_DATA} \
-platform ${OE_QMAKE_PLATFORM_NATIVE} \
- -xplatform linux-oe-g++ \
+ -xplatform ${XPLATFORM} \
${QT_CONFIG_FLAGS}
}
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index da6e999f..3a8b46c9 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -9,3 +9,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
SRCREV = "e3af14e9169207e0e73f7e50191106895c29ddc4"
+
+# The same issue as in qtbase:
+# http://errors.yoctoproject.org/Errors/Details/152641/
+LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index cda7b3ad..4ae870a1 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -2,6 +2,7 @@ require qt5.inc
require qt5-git.inc
require qt5-ptest.inc
+HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
diff --git a/recipes-qt/qt5/qtenginio_git.bb b/recipes-qt/qt5/qtenginio_git.bb
index 1fa8e826..30d5eeae 100644
--- a/recipes-qt/qt5/qtenginio_git.bb
+++ b/recipes-qt/qt5/qtenginio_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
QT_MODULE_BRANCH = "dev"
-SRCREV = "0555cf73c8b5abd41d8a4ff02457315c9e7c667d"
+SRCREV = "23603a3b088178d8ec92fddb240e5a5c55d77d5a"
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index eaa36611..c1bbc8aa 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -2,6 +2,7 @@ require qt5.inc
require qt5-git.inc
require qt5-ptest.inc
+HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPLv21;md5=4bfd28363f541b10d9f024181b8df516 \
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 50d2190f..b4f5a714 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -1,6 +1,7 @@
require qt5.inc
require qt5-git.inc
+HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPLv21;md5=4bfd28363f541b10d9f024181b8df516 \
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 93306035..f9e04c85 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -1,6 +1,7 @@
require qt5.inc
require qt5-git.inc
+HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPLv21;md5=4bfd28363f541b10d9f024181b8df516 \
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb
index 911a7098..0c6ce7e0 100644
--- a/recipes-qt/qt5/qtsystems_git.bb
+++ b/recipes-qt/qt5/qtsystems_git.bb
@@ -30,4 +30,4 @@ do_install_append() {
QT_MODULE_BRANCH = "dev"
-SRCREV = "f364358a817ba57fa5aa9c67e731241249e704f8"
+SRCREV = "9c204e05ae7fefe9525b30238b469b1bb65d2537"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 80896939..69305196 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -1,6 +1,7 @@
require qt5.inc
require qt5-git.inc
+HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index d4fccafe..8b706ddb 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -2,6 +2,7 @@ require qt5.inc
require qt5-git.inc
require qt5-ptest.inc
+HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
diff --git a/recipes-qt/qtchooser/qtchooser_git.bb b/recipes-qt/qtchooser/qtchooser_git.bb
index f7656450..e745e8ad 100644
--- a/recipes-qt/qtchooser/qtchooser_git.bb
+++ b/recipes-qt/qtchooser/qtchooser_git.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Wrapper to select between Qt development binary versions"
HOMEPAGE = "http://macieira.org/qtchooser"
LICENSE = "LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | GPL-3.0"
-SRC_URI = "git://code.qt.io/qt/qtchooser.git;branch=master \
+SRC_URI = "git://code.qt.io/cgit/qtsdk/qtchooser.git;branch=master \
file://0001-Makefile-install-the-man-dir.patch"
LIC_FILES_CHKSUM = " \
@@ -10,8 +10,8 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL;md5=4193e7f1d47a858f6b7c0f1ee66161de \
"
S = "${WORKDIR}/git"
-SRCREV = "4717841185d34bbe450e3b24445f2d35e3325a6a"
-PV = "39+git${SRCREV}"
+SRCREV = "a1b6736e4f2daf86cd1626004d40ef57db85fbb5"
+#PV = "39+git${SRCREV}"
inherit pkgconfig
diff --git a/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch b/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch
index a6da1ae4..d405c168 100644
--- a/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch
+++ b/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch
@@ -1,42 +1,31 @@
-From 878c5a2a47d620f36dd281d4b0eb6677a8a1fbd4 Mon Sep 17 00:00:00 2001
+From d8c16e032a6b639b410761a07f2158e0aeda0b08 Mon Sep 17 00:00:00 2001
From: Otavio Salvador <otavio@ossystems.com.br>
Date: Sat, 7 Jun 2014 18:13:14 -0300
Subject: [PATCH] build: Fix mkspecs and CMake module install directories
+
Organization: O.S. Systems Software LTDA.
Upstream-Status: Inapropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+Signed-off-by: Herman van Hazendonk <github.com@herrie.org>
---
- CMakeLists.txt | 2 +-
- pkg/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d78fedf..1f4db6b 100644
+index 0695a76..f2266c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -27,7 +27,7 @@ endfunction(QUERY_QMAKE)
+@@ -34,7 +34,7 @@ endfunction(QUERY_QMAKE)
query_qmake(QT_INSTALL_PLUGINS QT_PLUGINS_DIR)
query_qmake(QT_HOST_DATA QT_DATA_DIR)
-set(QT_MKSPECS_DIR ${QT_DATA_DIR}/mkspecs)
+set(QT_MKSPECS_DIR ${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs)
- # Configure options
- option(GENERATE_DOC
-diff --git a/pkg/CMakeLists.txt b/pkg/CMakeLists.txt
-index 25891a5..a87fedd 100644
---- a/pkg/CMakeLists.txt
-+++ b/pkg/CMakeLists.txt
-@@ -19,6 +19,6 @@ if(PKG_CONFIG_FOUND)
- )
- endif(PKG_CONFIG_FOUND)
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/FindTufao${TUFAO_VERSION_MAJOR}.cmake"
-- DESTINATION "${CMAKE_ROOT}/Modules"
-+ DESTINATION "${libdir}/cmake"
- COMPONENT development
- )
+ # Debug version of library should have 'd' postfix on Windows
+ # and '_debug' on Mac OS X
--
2.0.0.rc4
diff --git a/recipes-qt/tufao/tufao_1.2.1.bb b/recipes-qt/tufao/tufao_1.3.10.bb
index 34b28b78..d4b62e2b 100644
--- a/recipes-qt/tufao/tufao_1.2.1.bb
+++ b/recipes-qt/tufao/tufao_1.3.10.bb
@@ -3,8 +3,8 @@ LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=4fbd65380cdd255951079008b364516c"
DEPENDS = "qtbase"
-SRCREV = "a4832b4c941b5ff3f5fab23adcff39e6ad6cb4e5"
-SRC_URI = "git://github.com/vinipsmaker/tufao.git;protocol=http \
+SRCREV = "ad505c32d0ba14c3c616de8ba4c7eb79396c20a6"
+SRC_URI = "git://github.com/vinipsmaker/tufao.git;protocol=http;branch=1.x \
file://build-Fix-mkspecs-and-CMake-module-install-directori.patch"
# This includes bugfixes from 1.x branch