aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch')
-rw-r--r--recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch29
1 files changed, 9 insertions, 20 deletions
diff --git a/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch b/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch
index a6da1ae4..d405c168 100644
--- a/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch
+++ b/recipes-qt/tufao/tufao/build-Fix-mkspecs-and-CMake-module-install-directori.patch
@@ -1,42 +1,31 @@
-From 878c5a2a47d620f36dd281d4b0eb6677a8a1fbd4 Mon Sep 17 00:00:00 2001
+From d8c16e032a6b639b410761a07f2158e0aeda0b08 Mon Sep 17 00:00:00 2001
From: Otavio Salvador <otavio@ossystems.com.br>
Date: Sat, 7 Jun 2014 18:13:14 -0300
Subject: [PATCH] build: Fix mkspecs and CMake module install directories
+
Organization: O.S. Systems Software LTDA.
Upstream-Status: Inapropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+Signed-off-by: Herman van Hazendonk <github.com@herrie.org>
---
- CMakeLists.txt | 2 +-
- pkg/CMakeLists.txt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d78fedf..1f4db6b 100644
+index 0695a76..f2266c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -27,7 +27,7 @@ endfunction(QUERY_QMAKE)
+@@ -34,7 +34,7 @@ endfunction(QUERY_QMAKE)
query_qmake(QT_INSTALL_PLUGINS QT_PLUGINS_DIR)
query_qmake(QT_HOST_DATA QT_DATA_DIR)
-set(QT_MKSPECS_DIR ${QT_DATA_DIR}/mkspecs)
+set(QT_MKSPECS_DIR ${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs)
- # Configure options
- option(GENERATE_DOC
-diff --git a/pkg/CMakeLists.txt b/pkg/CMakeLists.txt
-index 25891a5..a87fedd 100644
---- a/pkg/CMakeLists.txt
-+++ b/pkg/CMakeLists.txt
-@@ -19,6 +19,6 @@ if(PKG_CONFIG_FOUND)
- )
- endif(PKG_CONFIG_FOUND)
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/FindTufao${TUFAO_VERSION_MAJOR}.cmake"
-- DESTINATION "${CMAKE_ROOT}/Modules"
-+ DESTINATION "${libdir}/cmake"
- COMPONENT development
- )
+ # Debug version of library should have 'd' postfix on Windows
+ # and '_debug' on Mac OS X
--
2.0.0.rc4