aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index b1866778..b42338ab 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -8,8 +8,8 @@ PACKAGECONFIG[qt5] = '--enable-qt \
# The GStreamer Qt5 plugin needs desktop OpenGL or OpenGL ES to work, so make sure it is enabled
python() {
- cur_packageconfig = d.getVar('PACKAGECONFIG').split()
+ cur_packageconfig = d.getVar('PACKAGECONFIG',True).split()
if 'qt5' in cur_packageconfig and not (('opengl' in cur_packageconfig) or ('gles2' in cur_packageconfig)):
- gl_packageconfig = d.getVar('PACKAGECONFIG_GL')
+ gl_packageconfig = d.getVar('PACKAGECONFIG_GL',True)
d.appendVar('PACKAGECONFIG', ' ' + gl_packageconfig)
}