aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2019-05-24 09:49:24 +0200
committerEike Ziller <eike.ziller@qt.io>2019-05-24 13:04:15 +0000
commit52d48c75ae6e00561fe128e5ba954817d73ca4d4 (patch)
tree082d94e802bb585dc58a7c089d13a118e1d29c52 /CMakeLists.txt
parentc4071d09adf41d4931944e8dc122ab4c6613c779 (diff)
CMake build/macOS: Centrally detect system libraries
And realize that at most places (except native help viewer) the code using them is not optional on macOS. Change-Id: I308406a0e8f176dad4151d23a33cd3fc0fb8635c Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81cad0edc8..53b379c3b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,6 +111,14 @@ endif()
find_package(LLVM QUIET)
find_package(Clang COMPONENTS libclang QUIET)
+if (APPLE)
+ find_library(FWCoreFoundation CoreFoundation)
+ find_library(FWFoundation Foundation)
+ find_library(FWAppKit AppKit)
+ find_library(FWIOKit IOKit)
+ find_library(FWWebKit WebKit)
+endif()
+
set(_IDE_APP_PATH "bin")
if (APPLE)